Need help? Check out our Support site, then

Visual Editor Not Displaying

  1. Hi all,

    I've just noticed this problem this weekend, while trying to write a new post on my blog.

    Basically, the text appears to be in 'HTML Editor mode'. There is a tab for the Visual Editor but, clicking that doesn't change anything. All of the Visual Editor icons are also missing (bold, italic, etc.), with the exception of the Upload/Insert icons, which are present in both formats. In HTML mode, all the relevant icons are present.

    I have already checked under Users > Personal Settings and the box to disable Visual Editor While Writing is unchecked. I have also tried checking and then unchecking it again.

    I'm using the latest version of Firefox. Javascript is enabled and I've tried disabling the ad-blocking software, etc. I've also tried loading WordPress in a fresh installation of Google Chrome (no add-ons) but still, the Visual Editor isn't loading or displaying correctly.

    Does anyone have any further suggestions? I haven't knowingly done anything that would've caused this.

    I'm using one of the 'free' accounts so, I'm not sure of my limitations as an administrator...

    Thanks for your time,


    The blog I need help with is

  2. Log out of wordpress, clear your browser cache and cookies, restart your browser and try again. Generally that will clear up dashboard related issues.

  3. Hi,

    Just tried that but, unfortunately, the problem persists.

    Thanks for the suggestion, though.

  4. If you have a different browser, try that and see if it is related to Firefox only.

    The other thing to try is to go to users > personal settings, set it to disable the editor and save. Then go to the editor and then close the editor and go back to personal settings and re-enable the visual editor and see what happens.

  5. Just tried that as well but, still no joy. Downloaded a fresh version of Safari 5 yet, it's exactly the same as in Firefox and in Chrome.

    One thing that I didn't mention before is that the page still appears to be loading in all browsers (that little icon keeps going round). I've tried waiting but, nothing seems to happen. I get the same thing reading my e-mails in Yahoo yet, it's never caused a problem.

  6. longshotsblues

    I just wish they would put the editors back the way they were.

    Visual, now you can't even go to full screen. No longer can change colors if you want. Everything seems to be gone. And I have done all the things suggested as well.

    Very frustrating.

  7. The color thing is right there were it has always been on the lower row of the visual editor icons: .

    The full screen editor has changed, but it is still there, just different. Some like it, some do not. It is not likely to change back though.

  8. longshotsblues

    Well this link displys the OLD format.

    The new one the Icons are gone.

    I go to Visual and there are only 11. There is no KITCHEN SINK ANYMORE TO OPEN Second row.

    Bold, Italic, abc strikethrough, align right, center, left, block quote links and unlink and Ordered and unordered lists. That is all.

  9. @longshotsblues
    I can see the kitchen link icon on my blog, provided I'm not working in the Distraction-free Writing full-screen writing mode. When we are in that mode we are provided with only a bare minimum of icons in a dingle toolbar row and we have to switch out of that mode in order to access the other icons. Are you working in the Distraction-free Writing full-screen writing mode? See here for more clarity and scroll down to "Introducing Distraction-free Writing".

  10. longshotsblues

    Yes I am in the distraction free writing mode not by choice. WordPress updated this and to my knowledge we were stuck with it. I've gone to personal settings than options. And I have the disabled Visual Editor unchecked because I want to be able to write in the Visual. Yet I see no way to get out of the Distraction free mode.

    I read the links you provided but I'm just not seeing where it says how you can get out of this new distraction free mode. That is the problem.

    I will re-read it again. But even the full screen option has been eliminated. Without the ability of full screen you can't see what the hell you are writing because your being blocked.

    So yes I'm the Distraction-free Writing full-screen writing mode, yet the full screen isn't there. But I don't know how to get out of this mode. One day it was just there.

  11. longshotsblues

    When I go to post a new blog I either have HTML or VISUAL.

    On HTML you can go to full screen but then you are automatically in Distraction Free Mode. No Icons at all. If you click on the Visual. No icons or full screen option period.

    So I'm not in distraction free Visual Mode. But everything is still missing. So like I said when WordPress changed this. This is what I've been stuck with. And I don't see how to change it back. According to the forums I was on weeks ago we can't switch it back so if you know how to get out of this annoying mode, please forward info. I've read the links, they were of no help.

    My kitchen sink is gone with my patience.

  12. longshotsblues

    On my Visual I only have row 1.

    1 through 11. 12-15 is not appearing. Number 15 is the kitchen sink. And I have no idea why 12-15 is gone but it is. I've cleared the cache turned the computer off than on again. I am only getting 1-11 on Row one.

    I cannot bring up 12-15 therefore cannot get Kitchen Sink number 15???????

  13. By "row one," do you mean the row beginning with the text format dropdown box (paragraph) and ending with the help button (looks like a question mark)? I am trying to figure out what it is you are seeing -- which tools you have.

    The shortcut on a PC for toggling the kitchen sink is Alt+Shift+Z, if that helps.

    If you are in full screen (distraction-free) mode, there should be an "exit fullscreen" link in the upper left-hand corner.

    If none of this works, you should contact staff:

  14. I should say, "if none of this works and no other volunteer has a solution for you, you should contact staff." :)

  15. The page to which thesacredpath provided a link does have the current visual editor schematics. The rows look just like they do in my visual editor (although the icon for fullscreen has been changed):

    The "row one" referred to in the support page on the visual editor contains the kitchen sink icon, so if you have row one, you should have the kitchen sink. If you have some random icons and you do not see essentially what is shown in the support doc, you should contact support, I think.

  16. longshotsblues

    There is no text drop down box. In this link you've provided. All I'm getting in row one is 1-11 icons. 12-15 do not exist and are not showing up.

    Considering others are getting all 15 I will contact support.

    Thank You for response.

  17. longshotsblues

    Well now the Contact Support page will not function. Says error on page?

    I Give Up.

  18. You can email support at [email redacted].

  19. longshotsblues


    Just sent off email. Hope they can tell me how to fix the problem.

  20. I hope so, too! It must be very frustrating.

  21. Same problem tried all suggestions was working but now its just stopped! changing from html to visual mode it just stays as html, this sucks.

  22. You can email support at [email redacted].

  23. longshotsblues

    Support did contact me and said it would be great if I could send them a screen shot of what I'm seeing. And provided a link to how to take a screen shot.

    Momma Mia!

    Your key may just have “PrtScn” written on it, as shown above.
    When what you want is displayed on the screen, press that key.
    Then open the graphics program you use (Paint, GIMP, Photoshop, GIMPshop, Paintshop Pro, Irfanview, Photofiltre – there are many more)
    You now need to paste the image into the program. This can be done by checking the Edit menu, by clicking in the main area and pressing Ctrl + v, or by the File > New menu. Each program is different.
    Once you have the image, you can edit it, resize it, or do anything else you need to do (like add annotations).
    You then need to export it or save it. It must be as one of these if you wish to blog the image:
    You can then upload the image to your blog or send it to Support as an attachment if you have been asked.
    Never send an image that you have pasted into a word-processor such as Word / Open Office to Support. These cannot be used.

    I found the Print/Screen button but I don't have any graphics programs and in reality don't want any. I just don't use these things. I have adobe photoshop but I couldn't figure out how to do what they are asking. I am no computer pro that's for sure.

    Basically I replied to them way to complicated for me or I'm not comprehending exactly how taking this screen shot is done. Then said just visualize last 4 Icons on first row not there. That's all that I could tell them. So problem is still there with Visual. I wish I could send them what they need, I just do not know how to do it.

  24. longshotsblues

    Now this is getting a little ridiculous. After all the information I sent. I just received this response.

    Hi There

    To be clear, are you saying that the second row of buttons is not showing up, or that it's showing up but the icons are blank?

    Note that you have to click on the "Kitchen Sink" button to toggle the second row of buttons. It's the last button (the right-most one) on the first row of buttons.


    I sent an email detailing everything very distinctively. That I was only getting 1 - 11 Icons on first row. And that 12-15 were completely missing and don't appear at all. I know number 15 is the kitchen sink. But can't click onto something to bring up second row when the 15Th icon Kitchen Sink is MISSING.

    Just getting downright mad now.

    I don't know why they had to mess with something that wasn't broke to begin with. They should of left the editors alone. But explaining this again and again to only gain this response?

    I made it quite clear that 12-15 Icons are not appearing. No number 15, therefore No Kitchen Sink.

  25. The editor does have to be updated to keep up with changes in browsers and also to keep up with changes in WordPress. Sorry, but that is the way of the web. Stuff changes and it changes rather quickly generally.

    Reply to staff and explain (sorry you have to do this again) specifically that the kitchen sink icon is not there at all.

    I've tried to reproduce this in Safari, Firefox, Opera and Chrome on my computer and cannot, so I'm afraid I can't even hazard a guess as to why this is happening for you.

    What browser and browser version are you using?

    Have you tried a different browser?

    What operating system are you on (XP, Vista, Windows 7, Mac OS X 10.x.x)?

  26. longshotsblues

    XP, IE8

    I like my browser and don't want to get another one. But if !E8 is the problem they should of updated to accommodate all the browsers.

    There is IE9 but it's only for Windows 7 and Vista. It isn't compatible with XP.

    Computers are like cars they're great when all the parts are functioning, when not they are a pain.

  27. BTW I already did explain it again when they sent their response.

    Thannks thesacredpath.

  28. When on the post editor page, switch either to or away from compatibility view (depending on which way it is set) and then force refresh the editor page and see what happens.


    Sorry, but Internet Explorer is the anti-matter of browsers. MS routinely thumbs their noses at web standards and they cause web software developers and web site developers to douse themselves in gasoline and then jump through burning hoops to make things work with their browsers. It is the ONLY browser that requires web developers to create specific CSS files for each of their browser versions (6, 7, 8 and 9).


  29. One thing you might try doing is to take a screen shot of your editor window showing the icons missing, upload it to your media library and then send them a link showing that it is missing.

Topic Closed

This topic has been closed to new replies.

About this Topic