Visual Editor Not Displaying

  • Author
    Posts
  • #646096

    ollypj
    Member

    Hi all,

    I’ve just noticed this problem this weekend, while trying to write a new post on my blog.

    Basically, the text appears to be in ‘HTML Editor mode’. There is a tab for the Visual Editor but, clicking that doesn’t change anything. All of the Visual Editor icons are also missing (bold, italic, etc.), with the exception of the Upload/Insert icons, which are present in both formats. In HTML mode, all the relevant icons are present.

    I have already checked under Users > Personal Settings and the box to disable Visual Editor While Writing is unchecked. I have also tried checking and then unchecking it again.

    I’m using the latest version of Firefox. Javascript is enabled and I’ve tried disabling the ad-blocking software, etc. I’ve also tried loading WordPress in a fresh installation of Google Chrome (no add-ons) but still, the Visual Editor isn’t loading or displaying correctly.

    Does anyone have any further suggestions? I haven’t knowingly done anything that would’ve caused this.

    I’m using one of the ‘free’ accounts so, I’m not sure of my limitations as an administrator…

    Thanks for your time,

    Olly.

    The blog I need help with is ollypj.wordpress.com.

    #646230

    Log out of wordpress, clear your browser cache and cookies, restart your browser and try again. Generally that will clear up dashboard related issues.

    #646232

    ollypj
    Member

    Hi,

    Just tried that but, unfortunately, the problem persists.

    Thanks for the suggestion, though.

    #646233

    If you have a different browser, try that and see if it is related to Firefox only.

    The other thing to try is to go to users > personal settings, set it to disable the editor and save. Then go to the editor and then close the editor and go back to personal settings and re-enable the visual editor and see what happens.

    #646238

    ollypj
    Member

    Just tried that as well but, still no joy. Downloaded a fresh version of Safari 5 yet, it’s exactly the same as in Firefox and in Chrome.

    One thing that I didn’t mention before is that the page still appears to be loading in all browsers (that little icon keeps going round). I’ve tried waiting but, nothing seems to happen. I get the same thing reading my e-mails in Yahoo yet, it’s never caused a problem.

    #646514

    I just wish they would put the editors back the way they were.

    Visual, now you can’t even go to full screen. No longer can change colors if you want. Everything seems to be gone. And I have done all the things suggested as well.

    Very frustrating.

    #646515

    The color thing is right there were it has always been on the lower row of the visual editor icons: http://en.support.wordpress.com/visual-editor/ .

    The full screen editor has changed, but it is still there, just different. Some like it, some do not. It is not likely to change back though.

    #646516

    Well this link displys the OLD format.

    The new one the Icons are gone.

    I go to Visual and there are only 11. There is no KITCHEN SINK ANYMORE TO OPEN Second row.

    Bold, Italic, abc strikethrough, align right, center, left, block quote links and unlink and Ordered and unordered lists. That is all.

    #646521

    timethief
    Member

    @longshotsblues
    I can see the kitchen link icon on my blog, provided I’m not working in the Distraction-free Writing full-screen writing mode. When we are in that mode we are provided with only a bare minimum of icons in a dingle toolbar row and we have to switch out of that mode in order to access the other icons. Are you working in the Distraction-free Writing full-screen writing mode? See here for more clarity and scroll down to “Introducing Distraction-free Writing”.
    http://en.blog.wordpress.com/2011/05/19/just-write/

    #646522

    timethief
    Member
    #646529

    Yes I am in the distraction free writing mode not by choice. WordPress updated this and to my knowledge we were stuck with it. I’ve gone to personal settings than options. And I have the disabled Visual Editor unchecked because I want to be able to write in the Visual. Yet I see no way to get out of the Distraction free mode.

    I read the links you provided but I’m just not seeing where it says how you can get out of this new distraction free mode. That is the problem.

    I will re-read it again. But even the full screen option has been eliminated. Without the ability of full screen you can’t see what the hell you are writing because your being blocked.

    So yes I’m the Distraction-free Writing full-screen writing mode, yet the full screen isn’t there. But I don’t know how to get out of this mode. One day it was just there.

    #646530

    When I go to post a new blog I either have HTML or VISUAL.

    On HTML you can go to full screen but then you are automatically in Distraction Free Mode. No Icons at all. If you click on the Visual. No icons or full screen option period.

    So I’m not in distraction free Visual Mode. But everything is still missing. So like I said when WordPress changed this. This is what I’ve been stuck with. And I don’t see how to change it back. According to the forums I was on weeks ago we can’t switch it back so if you know how to get out of this annoying mode, please forward info. I’ve read the links, they were of no help.

    My kitchen sink is gone with my patience.

    #646531

    On my Visual I only have row 1.

    1 through 11. 12-15 is not appearing. Number 15 is the kitchen sink. And I have no idea why 12-15 is gone but it is. I’ve cleared the cache turned the computer off than on again. I am only getting 1-11 on Row one.

    I cannot bring up 12-15 therefore cannot get Kitchen Sink number 15???????

    #646532

    mmadfan
    Member

    By “row one,” do you mean the row beginning with the text format dropdown box (paragraph) and ending with the help button (looks like a question mark)? I am trying to figure out what it is you are seeing — which tools you have.

    The shortcut on a PC for toggling the kitchen sink is Alt+Shift+Z, if that helps.

    If you are in full screen (distraction-free) mode, there should be an “exit fullscreen” link in the upper left-hand corner.

    If none of this works, you should contact staff:
    http://en.support.wordpress.com/contact/

    #646533

    mmadfan
    Member

    I should say, “if none of this works and no other volunteer has a solution for you, you should contact staff.” :)

    #646534

    mmadfan
    Member

    The page to which thesacredpath provided a link does have the current visual editor schematics. The rows look just like they do in my visual editor (although the icon for fullscreen has been changed): http://en.support.wordpress.com/visual-editor/

    The “row one” referred to in the support page on the visual editor contains the kitchen sink icon, so if you have row one, you should have the kitchen sink. If you have some random icons and you do not see essentially what is shown in the support doc, you should contact support, I think.

    #646538

    There is no text drop down box. In this link you’ve provided. All I’m getting in row one is 1-11 icons. 12-15 do not exist and are not showing up.

    http://en.support.wordpress.com/visual-editor/

    Considering others are getting all 15 I will contact support.

    Thank You for response.

    #646539

    Well now the Contact Support page will not function. Says error on page?

    I Give Up.

    #646540

    mmadfan
    Member

    You can email support at support@wordpress.com.

    #646544

    Thanks

    Just sent off email. Hope they can tell me how to fix the problem.

The topic ‘Visual Editor Not Displaying’ is closed to new replies.