Need help? Check out our Support site, then

Warning: Invalid argument supplied for foreach() in - blog is down

  1. Help please.

    I'm desperatley seeking some help please
    I have been experiencing quite a bit of down time lately with my host, Brinkster. After a while, they suggested using mysql5 instead of mysql4 which I was on.

    The tech support (they are usually very helpful) went ahead and swapped my database over. Then all hell broke lose.

    I changed the string in wp-config.php to mysql5... but I kept getting the same error (which you can see now at ).

    I couldn't find a problem in functions.php, so I didn't know what to do. I ended up replacing wp-config.php with a backed up version, after the tech help switched my back to msql4.

    I still had the problem, so I swapped the functions.php file with one I had from a back up. Still the problem...

    Please please please...I will be eternally greatful for any help on this.

    Thanks for your help.


  2. Dave

    I'm sorry to do this to you, but you need to be asking this over at

    Unfortunately these forums are only for support of blogs.


  3. Done. Now if you can help...I'd really appreciate it.


  4. We run a different code base than the standard WordPress that you do. You may also want to mention which version of WordPress that you are using.

    From reading the large number of occasions that this error has been brought up over there, I vote for an issue with a plugin. You may want to try turning them all off and seeing, after you clear your cache of course, if you still get the error.

    Good luck,

Topic Closed

This topic has been closed to new replies.

About this Topic