Need help? Check out our Support site, then

When I attempt to add a new user to my blog they do not receive an email.

  1. Hello there --

    When I attempt to add my account (this account sciencekae) to my bookstore's blog located at I do not get any sort of email to accept the invitation. I have checked my blacklist and spam folders and nothing has showed up and tried resending the invitation a number of times on two separate days (December 2nd and 4th). Interestingly enough, when I attempted to add a different user who did not have a account they did get the email and were able to accept the invitation. Our email addresses are on the same domain.

    Any help with this would be greatly appreciated and I am happy to answer any other questions to riddle out the problem. My account should be made an Administrator and I have access to both accounts.

  2. You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at If your question is about a self-hosted WordPress blog then you'll find help at the forums.

    If you don't understand the difference between and, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

  3. Perhaps there is a spelling error issue here. When I enter this is the error message: doesn’t exist
    Did you mean to visit any of these blogs, instead of — ScienceKDE

    The address is reserved and cannot be registered, but you can sign up and choose another one.

    Here's the link for contacting Staff.

  4. Oh, I'm not trying to add the user to my own blog -- this is just a user account for my store blog at

    Sorry if that was phrased weirdly. I don't really need a personal blog, just the ability to post on the staff one. =)

    Thank you for the quick reply, I really appreciate it!

  5. Hey there --

    I've left this for a week and seen no replies? Anyone have any ideas?

  6. Can you please try resending the invitation?

  7. Hey there --

    (Sorry for the delay)

    I've tried a few times to resend the invite as well as cancel and resend the invite to no avail! I just tried again to make sure nothing had changed and I still can't send an invite!

  8. Can you please try adding to your email's whitelist then try sending it again?

    Also, if you're using Gmail make sure that it isn't being caught by any auto-delete filters.

Topic Closed

This topic has been closed to new replies.

About this Topic