Need help? Check out our Support site, then

Where can I upload mp3's for the new WP audio player?

  1. Thanks for this new "Song & Movies on WP.COM" thing which was great to hear for me since I have a music blog. But I have one problem. It doesn't work for me :) You can check my blog and currently the latest post holds one player which stays still at "buffering" position.

    Ok now let me try to explain. It's said that, free accounts as well can use this feature as long as we can find somewhere to host our files. So I did and registered an account at Unlike rapidshare, I can use a 1 gb space to host my files, mp3s etc. And when I do the upload, it assignes an URL for it (to email others) which I believed was the same URL to use in tag [audio http://.....]. The URL ends with *.mp3 (not *.html or something)

    Is there any other address(es) you can offer? Or better than that, please tell me I'm doing something wrong and correct me.

    Thanks, thanks, thanks

    ps. please do not offer me the I already use it but honestly like the new player far better than odeo's :) PLUS, the new WP player doesn't work with the URL that ODEO provides for the mp3 file.

    ps2. could there be any problem with the theme I'm using? (I use the "REGULUS" theme)

  2. I'm having a similar kind of problem. My problem is the player won't work on IE for me. I have an mp3 hosted elsewhere and used the correct code. It works great on firefox but when I try on IE no luck. The sample on Songs and Movies won't work for me on IE as well. I've tried it on 2 different machines.

    I'm using IE6. For the sample song from the link above it just sits on "buffering". For my song hosted elsewhere it says "Error Opening File". For some reason the player works here when I use IE.

  3. Please send in a feedback to staff to advise them of your problem and include as much information as possible in it.

  4. I am hosting my files on Odeo and I have had the same problem, but only some of the time. Sometimes instead it says "error loading file" and sometimes it plays perfectly. It looks like you're using the right URL, the one ending in .mp3. You may want to contact your host with a pointer to the WordPress blog post explaining things; perhaps they can figure out where the interference is coming from on their end?

  5. Im having the same problem with the audio player.
    Any word on what should be done to make this work properly??

  6. Should I send in a feedback? and let them know that Im having the same problems, or would it be something that's fixed for everyone? It seems like everyone is really busy working on stuff around wordpress so I wouldnt send it in now, just want some feedback.

  7. I have no answer for this Chelsea but I do know staff are very busy and that they have the forum on rss feeds. I'm assuming they know there is a problem. If you feel you'd like to send in a feedback then you can do that.

  8. alright thanks, ill just wait it out :)

  9. I just remembered knoizki saying yesterday that he liked the new audio player. I don't know what time it is in Hong Kong but his blog is in case you want to check it out.

  10. It seems to be working on my end, although it didn't work for about four hours after I put it in at first. I'm hosting the MP3 at Odeo and using the new player just as they said.

  11. TT: hahaha you're right, I like the new player than the BIG PINK FAT from Odeo. However some people might still be asking how and where to download their mp3's, as per raincoaster, I'm also hosting my mp3 at Odeo because the one from the multiply account doesn't work (m3u extension is not supported by this new feature). So far, I like the sliding player - and I wish we can also use/fit it in the sidebar (at least a bit smaller).

  12. I sent feedback yesterday (22nd) about my IE issue. I also pointed to this topic in the feedback. Hopefully they can resolve all our issues because I really like this player.

  13. It's very strange: one of mine is working and one is not. The only difference between them is that one is in an Odeo podcast and the other isn't, although I'm not using the Odeo player and I didn't link to the podcast, I used the link to the audio, which didn't change after I put it in the podcast. All very glitchy and odd.

  14. I just posted a tutorial on how to stream your own audio files through the new player for free. Hope it’s helpful.

  15. thestatusjoe, I've done that, all my free mp3's are stored in my multiply account. However, the mp3 link is correct but when you use it via the new sliding player, it takes forever to load (buffering). I believe the link can only be used as a downlable file not a playable one (multiply has the separate playlist to play this). So I would prefer Odeo for mp3 to use this player.

  16. knoizki, i made an error in my tutorial, but just fixed it. at multiply, left-click the download button, then copy that new page's URL. then follow the next steps. that works for me. try it out and let me know how it goes?

  17. Hi joe, I know how to do it, but for some reason, it didn't work first few times after the new player was launched. I tried it again, and so far it's working. I guess rain is right, "sometimes is working, other times it's not". So I assumed it wasn't my mp3 links, the player itself has a problem a few days ago. Thanks for the help tho.

  18. I've determined that if you're hosting your soundfiles at Odeo, they won't work with our audio player here unless you put them in a podcast.

  19. raincoaster, have you tried

  20. thestatusjoe, for me your song just hangs on "buffering" on your tutorial page. This happens on both firefox and IE. Does anyone else have the same problem?

  21. Arthur, I'm not sure what's up, but you're not alone. It's never faltered for me -- I'm listening to my song right now -- but that's through Firefox on a Mac. I just tried it through Safari and IE for Mac and both hang on buffering.

    That tells me it's either browser incompatibilty or maybe users need their flash plug-ins to be up-to-date.

    Are you running Windows? Are your plug-ins up to date?

  22. Yes I'm using Windows. I just updated to the latest flash player on firefox and IE. No Luck. Both browsers hang on "buffering".

    Just for kicks I tried the sample on the Songs and Movies. On my first post of this topic I mentioned that the sample mp3 on that post won't play when I use IE. But it works now. But it still doesn't work on IE for my mp3s I host elsewhere.

    I still haven't received any response from my initial feedback that I sent on the 22nd so I'm still hoping for a solution.

  23. thestatusjoe, thanks for the suggestion but as long as I've got one service that's working for me I'm cool with that. It's just frustrating that it took so long to find out the trick to making it work.

  24. arthur, i'm kind of stumped about your problem, too. hopefully it'll get ironed out for you soon enough, as well as for the others whose experience still seems finicky. it's a cool plug-in and it would be a bummer to know that even if audio plays for me -- it might not for everyone.

    coaster, i'm glad your way is working; i'd read your blurb about it having to be in a podcast and mistook that as being a problem. :)

  25. No, you know how it is. "It's not a bug, it's a FEATURE!" It's just an arbitrary weirdness with no documentation that we Odeo users have to work around.


    I listed the problems I am having with the new audio option in that thread (including the buffering issue). I didn't realize that the thread was marked resolved when I posted in it. I don't think that it fits 100% here, but perhaps someone will see this link and be able to help. If posting this isn't ok, please delete it. I am just looking for some help.


  27. I sent in feedback a couple days ago about this problem, but I havent heard anything back yet.
    thestatusjoe - I tried your post as well and for it your audio stays on "buffering" and doesnt move, as well the first time I loaded your post it said "error loading" and after I refreshed it wouldnt pass the buffering stage.
    I would really appreciate it if someone could check out my post and let me know what the goings on is with mine. For me - it says "buffering" and doesnt move.
    I just wanna get this resolved because I think this feature could be really awesome if it worked out for everyone.

  28. Chelseasrev. I get Buffering when I check yours.

  29. Chelsea, yours is stuck on buffering for me. Two of mine are working fine now, but the latest one isn't, for whatever reason. Back to Odeo to tweak it for no good reason, I guess.

    Does whether or not it's a live link contained within the square brackets matter, do you think?

  30. I'm not sure what you mean by live link? What exactly is the difference, for mine I took Qaan's advice from the top of this thread and used esnips, although it was my first time using it. Maybe I should try Odeo or something.

Topic Closed

This topic has been closed to new replies.

About this Topic