Why are “comments off?”

  • Author
    Posts
  • #310673

    abrabennett
    Member

    Hi all, and happy holidays. I just put up a post and it shows as having comments off, although I didn’t do anything to make that happen and cannot even see anywhere to turn the comments on or off for a specific post. Is it me, or is something funny going on today?

    http:frenchletters.wordpress.com

    #310947

    mark
    Staff

    Edit the post and look under the writing area. You can switch comments on/off there.

    #310960

    abrabennett
    Member

    I don’t have anything to switch comments on or off – the only thing that appears under the writing box when I edit is Add A New Category. Other people have a comments box? Or I’m just going blind?

    #310963

    Go to the “screen options” tab at the top of the screen and activate “discussion” on the visual editor page. Then expand the “discussion” bar and set the post to allow comments and re-save the post.

    Also, go to settings > discussion and make sure that “Allow people to post comments on the article” is selected. Make sure to click “save changes.”

    #311036

    zakmartin
    Member

    Hi,
    I’m having the same “Comments Off” issue as abrabennett, above, but I can’t follow your instructions. You say “Go to the “screen options” tab at the top of the screen and activate “discussion” on the visual editor page”.

    I can click on “Screen Options”, but there’s no mention there of “discussion”.
    And where is the visual editor page? I can’t find any page of this name.

    When I click on “Screen Options all I see are eight titles with a tick box beside each (all ticked):

    *Right Now *Recent Comments *Incoming Links *Your Stuff *What’s Hot *QuickPress *Recent Drafts *Stats

    Nothing about “discussion” or visual editor page.

    In settings, “Allow people to post comments” is ticked.

    But my most recent post still has “Comments Off” at the bottom.

    Where am I going wrong?

    #311037

    @zakmartin: The site linked to your name is not a wp.COM blog. If you don’t have a wp.com blog, you’re in the wrong forum; if you do, you should give us the link to it when you ask a question.

    (As for your main question, you’re in the wrong screen.)

    #311038

    zakmartin
    Member

    Hi,
    Thanks for responding to my query…
    My blog is at:
    http://zakmartin.wordpress.com/
    and I got to this forum by clicking the “Help” link on my dashboard.
    What do you mean, I’m in “the wrong screen”?
    I’m just trying to find out why it says “Comments Off” under my latest post, and how to change it to “Comments On”.
    Cheers,
    ZM

    #311039

    Open the post for edit in the editor. Then click on the “screen options” button and make sure “discussion” is selected. The click on the discussion title bar below the editor window. There you can turn comments on.

    #311040

    Also go to settings > discussion and make sure that “Allow people to post comments on the article” is selected. If it is not, select it and then click “save changes.”

    #311041

    zakmartin
    Member

    Thank you! Much appreciated.

    ZM

    #311042

    You’re welcome.

    #311043

    (@zakmartin: Now you know what I meant by “wrong screen”. You were in the main dashboard screen while tsp was talking about the post editor.)

The topic ‘Why are “comments off?”’ is closed to new replies.