Why are featured images not showing in Email to subscribers or Facebook?

  • Author
  • #1462953


    Featured images in posts not showing in Email to subscribers or Facebook (via Publicize). The blog on which I have noticed this consistently is http://klemcoll.wordpress.com – the only solution seems to be re-editing the post, by deleting the image in the post, removing the featured image, and then re-uploading the image, re-setting the featured image, and updating. But this does not correct the emails already sent, or sharing to Facebook via Publicize. Do you know what causes this currently/intermittently? Has anyone else reported this problem?

    The blog I need help with is klemcoll.wordpress.com.



    Who has access to your log-in information and/or email address?

    Did you use the same password for your email account and your blog?

    Are you sharing log-in information with anyone or leaving it where anyone can locate it?

    Are you remaining logged in on your computer so anyone can come along and access your blog through it?

    Go to your email program and change the password to a very difficult one because that’s how many hackers gain access to blogs.

    Then read this please knowing that blogs don’t get hacked when security protocols are followed. > http://en.support.wordpress.com/security/

    1. If you can log-in go here > Users > All Users and delete any user that does not belong there.

    2. Disable post by email > http://en.support.wordpress.com/post-by-email/

    3. Disable post by voice > http://en.support.wordpress.com/post-by-voice/

    4. Change your blog password to a very difficult one > http://en.support.wordpress.com/passwords/#change-your-password

    5. Use a secure, encrypted connection to connect to your Dashboard. Under Users → Personal Settings, check the box that says “Always use HTTPS when visiting administration pages, and click Save Changes.

    I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.



    RATS! I forgot to clear my browser.
    I’m so sorry. This is what I meant to post.

    I’m sorry but when using Publicize, note that we have no control over the images that Facebook chooses to display or when they choose to flush their image caches. We really only send them the URL of the post, and they hunt through that for the excerpt and images to include. From: https://en.forums.wordpress.com/topic/avalaible-facebook-thumbnail-issue?replies=7#post-1000734
    Read also: http://developers.facebook.com/tools/debug
    from: https://en.forums.wordpress.com/topic/fb-link-has-no-thumbnails?replies=4#post-936861



    Hi Timethief, that’s more on target! :)
    I understand the pure FB issue using Publicize, but the real problem is that the subscriber emails are suddenly not carrying the featured image (just the Gravatar logo/image), and the appearance (or lack thereof) is 100% consistent with what shows up on Facebook (via manual share and/or via Publicize), so the problem appears to be in WordPress, related to settings/glitch in putting the featured image into the emails. It started happening about 3 weeks ago, and as I said in the first message, we can get it to reset by editing the image in the post, and updating the post, but this does not fix the problem in the emails already sent. Other ideas, just regarding the emails (forget about Facebook)?



    I’m sorry. I had too many browser windows open and got mixed up. There are no other ideas re: this long standing issue. Sorry. :(

The topic ‘Why are featured images not showing in Email to subscribers or Facebook?’ is closed to new replies.