Need help? Check out our Support site, then

Why are my photos disappearing when I save the draft of my post?

  1. silverblackbird

    Oh, I also meant to say that when I finally managed to get one post to publish with pictures (by not saving it first) it did work on something like the third attempt, but when I then tried to edit the published post - thinking it was now fine - the pictures went again.

    Please help!

  2. I am having the exact same problem. I've also tried saving/uploading the images in different formats (png, jpg) but nothing works. The pix show up in my Image Gallery, and they show up when I first compose the post, but when I hit 'save draft,' they disappear. Nor do they appear in Preview. But they are still in my Gallery - more and more of them now. Argh! Thanks for the help.

  3. So, it sounds like most of you are using Firefox. I'd like to at least narrow it down to that if possible (though I haven't been able to reproduce the problem on Firefox yet myself).

    Would you folks please try a difference browser, like Chrome, Safari, Internet Explorer, etc?

  4. cindybarganier

    I have been having all of these problems for weeks and I am using Internet Explorer and Chrome. I am about ready to leave WordPress. My numbers are falling like a rocket because I can't get anything ready to post. I have re worked every post at least 6 times. Out of desperation I posted one today with half of the images available and told my readers that I gave up trying to get it right and asked for insight. This is beyond ridiculous.

  5. silverblackbird

    Chrome hasn't worked for me either. Also, I haven't updated or changed my browser since the trouble began so there's clearly a problem in WP rather than our browsers!

  6. I can be absolutely precise about this. My problem with photos began on Monday evening (UK time, between 9pm and midnight, when I gave up in fury). I use Firefox, but have encountered the identical problem when using Chrome.

    I'm not about to leave WordPress. I don't need 'numbers'. This problem is really just a minor irritant. My blog is merely a shop window, that gives me fun to write and a handful of friends a laugh to read. I can point potential clients to it, and it therefore gives me some industrial credibility.

    WordPress is free, and I greatly value it. If this recent glitch can be fixed, I will be grateful. If not, however, <shrug> I can work around it. What I'm doing is drafting the text ahead of time, and then simply loading photos later and stabbing the Publish button. It takes a small handful of femto-seconds more, but hey .....!

  7. Hm, I'm unable to duplicate the listed steps in any browser. Have you tried with all browser extensions and add-ons temporarily disabled?

  8. What I would like is for the ease and user-friendliness of the system, as used successfully for months previously, simply to be restored. Nothing on my computer has changed, or has been changed. What has changed appears to be something within WordPress, and it happened suddenly and identifiably, 10 days ago. I really don't want to screw around with changing settings from those which suit me well, and which were previously operating in perfect harmony.

    This is not MY problem, silverblackbird's problem, cindybarganier's problem, brujaha's problem, leculentrelesdeuxchaises' problem, thistimethisspace's problem, timethief's problem, kswiberg's problem, xandergc's problem or chriskafer's problem. It is YOUR problem.

    We have, separately, used the forums to advise of a problem. Please don't try to throw it back at us, like some harassed teenage android in a benighted Bangalore sweat-shop call-centre/center.

    It would be nice if this trivial niggle could be identified and fixed. If it can't, I can live with that. Others can't, it seems.

  9. I'm not throwing it back at you, and I am not "some harassed teenage android in a benighted Bangalore sweat-shop call-centre/center."

    I'm just trying to troubleshoot this so we can isolate the issue or at least create some sort of test environment.

    I cannot reproduce the issue, which means that it works fine as far as I can see. What I need to do is knock down the variables, so I can hopefully reproduce the issue and of course fix it. What are the variables? I don't know unless you are able to try some things on your end as well.

    Now, have you tried with all browser extensions and add-ons temporarily disabled?

  10. And...given some of the things I've been reading lately, have you checked to make sure your virus scanner is up to date, like within the last two days, and run a scan?

  11. Just to add, we have had two similarly reported cases yesterday that were resolved by disabling Firefox's browser add-ons. We haven't heard back regarding which specific add-on was causing the trouble, so we are not able to confirm ourselves.

    You may have not added any new add-ons recently, but an automated update to an existing add-on could have easily introduced a new bug.

  12. If I have not used Firefox do you have any thoughts? I am on a brand new Dell AND am using Windows 7 for the first time. So I am wondering if there is a combination of components that are working against me. I use technology all day but am by no means "savy" so I am at your mercy. I am just frustrated because I am spending so much time that I don't have on this and am getting no where. Thanks for trying to help!

  13. Me again. How do I disable browser extensions and add-ons?

  14. Macmanx, I tried doing as you suggested. The only things I left live on Firefox were Ghostery, Priv3 and Adblock Plus. It still didn't work.

    So then I tried uploading my pix via Safari instead. It worked!

    So yeah, it seems to be a Firefox bug. I went back to Firefox and disabled those 3 plugins too - and my uploaded images appeared. I could also add new ones now. This is really sad to me because those things make my online life so much more pleasant.

    Thanks for the tip.

  15. The only things I left live on Firefox were Ghostery, Priv3 and Adblock Plus. It still didn't work.

    Ghostery is a known issue and so is DNT Do Not Track ther bloggers already reported that here. I would disable all three of those and see if your problem is resolved. if it is then you can enable those one at a time and find the culprit, knowing sometimes there is more than one culprit.

  16. ther bloggers = as other bloggers

  17. silverblackbird

    When I tried to post yesterday I got a message saying the site was down for maintenance (something like that!) and when it came online again I managed to save a draft with pictures - yay! Er, but ten minutes later I edited an earlier post to add tags and the photos from that one vanished.

    Re add-ons - it's fine saying that ghostery is a problem - and I do have it - but I've checked and it hasn't updated in the period that I've been having these problems. Ie nothing has changed at my end. Plus I tried using Chrome - with no add-ons - and I still had the problem. I'm glad someone is looking at it, but any more ideas? Thanks!

  18. Just to cross reference again - same problem is discussed here:

    I do not have the problem with Safari ... and when I pause blocking some trackers (for details, see my answer of 20-09-12 in the other thread).

    Good luck!

  19. Silver blackbird has a good point:

    "Re add-ons - it's fine saying that ghostery is a problem - and I do have it - but I've checked and it hasn't updated in the period that I've been having these problems. Ie nothing has changed at my end. Plus I tried using Chrome - with no add-ons - and I still had the problem. I'm glad someone is looking at it, but any more ideas? Thanks!"

    Same with me. Firefox with Ghostery, etc. had been working just fine, up until the moment it wasn't. I'm not aware of having updated anything either. So perhaps the problem lies not with Firefox's addons, but in the interface between these and something new that WordPress has done?

    I add my thanks for your continued sleuthing.

  20. @brujaha: I suspect the same.

  21. Ghostery itself is not updated frequently, but its definitions which define what is "bad" and in need of blocking are.

    It sounds like a recent update to those definitions have incorrectly blocked a script that we need to make the editor function properly. This happens from time to time with ad blockers, so I suppose a script blocker isn't outside the norm.

    As we have no control over what Ghostery blocks, I recommend contacting them to report the false-positive.

  22. Disabling ghostery on seems to have solved the problem for me. Thanks for the detective work.

  23. leculentrelesdeuxchaises

    I don't want to have to disable Ghostery or NoScript. The frustration comes from whatever changed at WP in the past couple weeks that caused this problem. I've already enabled too many different cookies and scripts just to get basic functionality, but now that's not even an option. I *will not* just turn either off for the sake of WP.

    It's true that the photo-disappearing problem isn't an issue when I use stripped-down Safari, but I don't like Safari and I really don't like that WP isn't letting me use Firefox.

  24. Dear macmanx,

    Mea maxima culpa. I really shoulda oughta put a smiley on my post. What arguably reads as an ill-natured rant was intended as just a bit of banter. I never lose sight of the fact that this is a free service, and I am grateful for the support that is available.

    Although I had earlier found it impossible to load properly in Chrome, something in their settings (at least) has clearly changed, as I have been able to load my most recent post with the same ease as had previously been the case with Firefox.

    I would much prefer to be able to use Firefox but, hell, if it's got to be Chrome, then let it be Chrome.

  25. leculentrelesdeuxchaises, nothing changed on our end. The problem is a recent definitions update to Ghostery so that it now blocks a script that the editor needs to operate.

    This is not something that we can fix. It's up to Ghostery to correct the false-positive.

    webwrights, not a problem, you should be able to use Firefox if you disable Ghostery or whitelist

  26. Ghostery disagrees:

    All I know is after disabling ghostery (only on WP) the behavior stopped.

  27. I think they may be confused between WordPress (the software) and (the blogging service)

    There are some differences between and, one of those includes how we handle some scripts throughout the Dashboard.

  28. I just want to say I've been having the same problems: pictures posting perfectly and then disappearing randomly 1-2 days after. I would re-insert the pictures. They would disappear again. I was ready to stab something.

    Today I disabled all my Firefox plug-ins and the problem is magically fixed. I'm so happy to have all my pictures back!

  29. This is so very very frustrating. AFter a month of not posting - I go back in to catch up and none of my photos uploads are working - it's completely different than before. Everything was so straight forward before and I was just recommending wordpress to a friend but after 2 hours of frustration on a rainy Sunday trying to get one simple blog post posted I'm about to slash my wrist. What is the solution here? Before I could simply upload single photos and add captions, etc, now the system seems to want to put everything in a gallery and then not show the images which makes it impossible for me to publish the blog as I haven't a clue what is going on.

  30. cindybarganier

    Try switching to a different browser. I started using google chrome and it stopped. I know it is frustrating. It took me so long to figure it out that I lost about 200 regular readers but I am finally up and running again. Good luck to you!

Topic Closed

This topic has been closed to new replies.

About this Topic