Why are my .png files not transparent?

  • Author
    Posts
  • #824992

    My .png files aren’t transparent. How can I fix this?
    Blog url: http://cherylmurphywrites.wordpress.com/

    #825108

    macmanx
    Staff

    They seem to be transparent, which ones are you referring to?

    #825112

    http://cherylmurphywrites.files.wordpress.com/2012/02/photoshopsignature.png
    http://cherylmurphywrites.files.wordpress.com/2012/02/handsignaturevector.png

    Neither one of them are coming transparent. I’ve checked in both chrome and safari. They are in a white box on my blogs.

    #825115

    macmanx
    Staff

    Are you sure that they were uploaded with transparency?

    #825119

    I don’t think I understand what you mean. As far as I know, there isn’t an option when you upload. I created them transparent, trying both illustrator and photoshop since I couldn’t figure out why it wasn’t working. They are transparent images.

    #825139

    I just created another transparent png file in now a third different way and still no transparent file on my blog.

    #825226

    yoavf
    Staff

    The images are indeed transparent, but the theme you’re using is adding white background too all the images in a post.

    This should be able to overwrite using the some CSS and the Custom Design upgrade:
    http://en.support.wordpress.com/custom-design/

    You can also overwrite this on a per image basis, by adding inline css to the image tag in the html editor.
    Something like this should work:
    <img src="http://cherylmurphywrites.files.wordpress.com/2012/02/photoshopsignature.png" style="background:transparent;" />

    Hope this helps.

    #825282

    I tried adding the html. It didn’t work. :( I don’t plan to upgrade because I don’t make any money off of the blog.

    Thank you for trying, though. I guess I just have to live with it.

    #825293

    evarlese
    Staff

    Okay, if you’d like, we can take a look at the post you added the inline CSS to. Would you mind sending a link?

    #825304

    http://cherylmurphywrites.wordpress.com/2012/02/14/the-confusion-of-setting/

    But some more info:
    When I just added the line as given above, it simply put another, full sized image in, also not transparent.

    So I tried to chop it down to just style=”background:transparent;” and add it into the already placed html size (which is the current set-up) and that didn’t make it transparent. If you want, I can just take out the other html and just use the one line (which just put the full sized image in with no transparency).

    I don’t know what would be more beneficial to you. I’m not familiar enough with html to know exactly what I’m doing but I’m always willing to play with it until I get what I want. Unfortunately that isn’t always very effective. :)

    #825346

    macmanx
    Staff

    That does appear to have worked in this case, but the old images may be caught in your cache.

    Would you please try clearing your browser’s cache?

    http://support.google.com/accounts/bin/answer.py?hl=en&answer=32050

    #825359

    After clearing cache: It totally seems to have worked here but not on the other one. Or maybe it’s just that it has a border I can’t seem to get rid of and it’s making me think it’s not transparent?

    #825360

    macmanx
    Staff

    Yep, it’s definitely transparent at http://cherylmurphywrites.wordpress.com/2012/02/14/the-confusion-of-setting/

    The border is applied by the theme and not affected by transparency.

    #825361

    Okay, then I guess I’ll live with it.

    Thank you all so much for your help! At least now I can make sure it’s transparent.

    #825363

    macmanx
    Staff

    You’re welcome!

The topic ‘Why are my .png files not transparent?’ is closed to new replies.