Why are there no bars in my "Stats" window?

  • Author
    Posts
  • #1070416

    kruggeri
    Member

    I get automatic update notifications whenever there is something new for either package and I always accept and run the updates.

    There are no updates currently waiting for me.

    Thanks.

    #1070417

    kruggeri
    Member

    It does work on my IE (which is out of date because it isn’t used in my office any more). The bars even show up in Chrome on a coworker’s computer.

    I don’t know what’s wrong with my Chrome. It should be up to date.

    #1070418

    booksnobbery
    Member

    This is what mine looks like right this moment: http://screencast.com/t/5wvUWalhcBFj

    I’m all updated on everything. It’s happening in Chrome, last I checked it wasn’t in firefox, but the recent flash update crashes my firefox every time I try to open it. :)

    #1070419

    kruggeri
    Member

    I haven’t downloaded another browser, but maybe I will try it…or try downloading Chrome again.

    #1070420

    markjr84
    Member

    You can add me to the list too please.

    I’m using Chrome Version 23.0.1271.64 m. I do get the graphs in other browsers but I prefer to use Chrome.

    #1070428

    I’ve got no stats for several month now on Win7 64 (all updates), OS-X 10.6.8, OS-X 10.7.5 (all updates) with the latest Firefox (…15, 16, 17) and the latest Java and Flash updates.
    I deleted cookies, accepted all cookies, deleted history, even used a completly new Firefox profile. No luck.

    For some reason stats in Safari (5 and 6) work fine on either system.
    Since I don’t like Safari at all this bug ist most anoying.

    #1070429

    jenia
    Member

    Could you please check if there are any errors displayed in the Javascript console in Chrome: View > Developer > Javascript Console? (Or, Firefox: Tools > Web Developer > Web Console, make sure JS is clicked.) If you could upload a screenshot of what you see there, it would be helpful in order to investigate this issue further for you.

    #1070430

    booksnobbery
    Member

    I hit ctrl+shift+j to open the javascript console. This is what I see when viewing the stats at wp.com: http://screencast.com/t/rVmObPxmxNN3

    This is what I see on booksnobbery.wordpress.com/wp-admin/index.php?page=stats: http://screencast.com/t/RTapWm1S

    It doesn’t look like there are any errors on either.

    #1070431

    tandava108
    Member

    I can confirm that there are no errors on my console. The fault occurs with no extensions loaded too (start chrome with –disable-extensions)

    #1070432

    booksnobbery
    Member

    I also disabled all of my extensions while checking. Still nothing.

    (Jenia, thanks for being here on Thanksgiving!)

    #1070433

    macmanx
    Staff

    Thanks for letting us know!

    We’re still looking into this.

    #1070445

    Just wanted to add myself to the list. I also have not had bars for several weeks now. Everything is up to date and I don’t have any errors on my javascript. I would also like to continue using Chrome…
    Thanks!

    #1070446

    joen
    Staff

    We’ve been hard at work debugging this issue, and we’re so stumped we think the issue may be related to a recent release of Chrome.

    We’re speculating that a change related to hardware acceleration made to Chrome 23 and newer may conflict with the stats chart on some hardware configurations.

    In order to verify whether or not this is the case, we ask that one of you who has this issue try the following:

    1. Visit the page chrome://flags/ in your Chrome browser
    2. Click “Enable” next to the two items shown in this screenshot: http://cl.ly/image/150b1m3k0L0r
    3. Restart the browser and see whether the bars have returned

    Important: before you do this you should know there’s a risk associated with changing these settings, so you should not do this unless you’re logged into Chrome with your Google account, so your bookmarks and settings are backed up. Worst case scenario, Chrome won’t start after changing these flags, and you’ll have to reinstall. I don’t think this is likely, but knowing is half the battle.

    Please let us know if changing these settings makes the chart work again.

    Thank you.

    #1070447

    grantconklin
    Member

    Joen, It worked!!!!

    #1070448

    joen
    Staff

    YAY! So glad to hear it, grantconklin! That’s good news, now we know what the problem is!

    I’m going to file a bugreport with Google, and hopefully they’ll fix it in the next version of Chrome.

    That also means that until Google fixes this issue, there are unfortunately only two solutions for users who are experiencing this issue: either change the flags as suggested above, or use a different browser to view stats.

    #1070450

    kruggeri
    Member

    Good to know.

    Thanks for everybody’s help.

    #1070454

    tandava108
    Member

    I have found that I only need to enable the “Disable accelerated 2D canvas” flag to get the stats bar back.

    #1070455

    joen
    Staff

    That’s very helpful tandava108, thanks for that info.

    #1070456

    markjr84
    Member

    Hi Joen, Thanks for that, it works for me too. Should we leave these 2 settings as “Enabled?”

    If I do leave them enabled (which I’m happy to by the way) could these settings affect anything else in Chrome?

    It’s just as a matter of interest just incase something else is affected down the line! :-)

    Thanks for your help!

    #1070457

    joen
    Staff

    @markthinksdotnet

    Good question. The answer is a bit technical.

    Google Chrome is continually developed and Google is trying to make everything render faster. That means offloading tasks on to the hardware, rather than computing it in software. The recent change Google made, was to have “canvas” elements be rendered by the hardware — the stats chart is a canvas element. When this is rendered by hardware, it renders faster and uses less battery on mobile computers.

    Enabling the “Disable accelerated 2D canvas” flag reverts the behavior, so canvas elements are rendered in software again.

    I believe flags are reset for every new stable major version of Chrome there is. So come Chrome 24, hopefully Google will have fixed this issue, and the flag should be reset automatically as you receive the update. Stable Chrome updates are usually 6 weeks apart. I could be wrong though, that flags are set until you unset them (or the are removed).

    If setting the flag makes the chart work for you, I can’t think of any downsides. In fact, other websites that use the canvas element should be more compatible as a side-effect.

    But the real solution is for Google to fix the bug so you don’t have to use the flag.

The topic ‘Why are there no bars in my "Stats" window?’ is closed to new replies.