Why can I sometimes not choose the "large" option when uploading images now?

  • Author
  • #1081413

    Hi, I’ve had my wordpress blog for quite awhile but recently have been having some strange image uploading issues. I’ve always uploaded my images at about the same size either 750 or 1000 pixels wide, I make sure to save them optimized so they are small files and then I chose the “large” setting. Lately, some photos I cannot chose “large” though. In a recent post you can see some photos fit the whole column and others come out much smaller:

    I’ve looked through forums, searched the internet, messed around with every suggestion I could find, emptied caches, tried different browsers. nothing works and it seems totally random, two photos at the same size will not necessarily act the same. I have deleted images over and re-edited them. Please help, I’m very frustrated.

    The blog I need help with is putyourhandstowork.wordpress.com.



    You can set the ‘Large’ size at Settings -> Media in your blog’s dashboard.

    The Media Settings allows you to control how your media is displayed. Image sizes allows you to change the maximum dimensions of images that are displayed on posts and pages. When setting a thumbnail size, the image will be cropped and resized to the setting. Medium and large images will keep the dimension proportions, taking the maximum width and height into account


    I understand how to set the media settings and have tried adjusting them but that does not seem to be helping the issue.

    If you click on the post I linked to in my question you’ll see that my images are displaying at 2 different sizes even though they have been resized to the same size before upload and are both on the “full size” setting. I cannot figure out why some photos are filling the column but others are only allowing a full size of 450 pixels. The option for “large” at upload is also only available with the pictures are displaying correctly as well.



    Hi Erika,

    I took a look, and it seems like this only applies when you have a caption on the image. I’m going to check with the theme folks and see if that’s working as designed, or if there will be a change down the line!

    We’ll keep you posted!




    I checked with our theme folks, and this is how the theme is intended to work. The images with a caption are constrained to the “official” content width of 450px (you can see that on your Custom Design page: https://putyourhandstowork.wordpress.com/wp-admin/themes.php?page=editcss)

    You have a couple of options at this point:

    *You can switch themes (I think your blog looks awesome, though, personally)

    *You can buy the Custom Design Upgrade, and change your content width so that those images will match the larger size you want.

    *You can change your larger photos to match the smaller ones (I love the look of those full-width images, as I suspect you do as well).

    *You can stop using captions and instead after an image hit shift+return for a soft return, set your text to italic, and kind of create a faux caption instead using a real caption.

    *You can do none of these and continue as-is.

    So I hope that one of those options works out for you, but let me know if you have further questions!


    zandyring! Thank you so much. I knew there must be some pattern to it but obviously I just couldn’t see what it was. Now it is so glaringly obvious. I did have the Custom Design Upgrade but it expired and now am more motivated to renew that.

    Thank you so very much for helping me with this. I haven’t posted on my blog since I couldn’t figure this out but now I feel much more positive about blogging again! (And thanks for your kind words about my blog!)



    I’m thrilled you’ve gotten some renewed enthusiasm for getting back into it! A nice blog like yours shouldn’t go to waste!

    Happy blogging!

The topic ‘Why can I sometimes not choose the "large" option when uploading images now?’ is closed to new replies.