Why can not non-registered people comment on my blog?

  • Author
    Posts
  • #1070111

    omppuzet
    Member

    I have diabled “Comment author must fill out name” and “e-mail and Users must be registered and logged in to comment” in the Discussion Settings but still non-registered people can not send comments on my blog. What is wrong?

    The blog I need help with is omppuzet.wordpress.com.

    #1070247

    timethief
    Member

    This page > Settings > Discussion is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    Discussion Settings
    Other comment settings
    _Comment author must fill out name and e-mail
    _Users must be registered and logged in to comment

    Note that the prompt to submit and email address and a website URL will still appear but providing an email address and logging in are not required.

    You can post instructions for your visitors in a text widget if you wish. That’s easy to do. You copy and paste this into a text widget:

    Readers: Note that the email address and logging in prompts do appear for comments on this blog, but providing an email address and logging in are not required.

    See here and read about how to set up a text widget. http://en.support.wordpress.com/widgets/text-widget/

    P.S. Currently over 80% of all so-called comments submitted to WordPress.com blogs every day are spam. Be sure to set up full comment moderation ie. “An administrator must always approve the comment” because anonymous commenting is bound to increase the amount of spam your blog will receive.
    http://en.support.wordpress.com/settings/discussion-settings/#comment-moderation

    #1070271

    omppuzet
    Member

    Thank you. Problem solved. I didn’t realize that the email and url fields appear anyway.

The topic ‘Why can not non-registered people comment on my blog?’ is closed to new replies.