Why can't I see the visual editor?

  • Author
    Posts
  • #914294

    macmanx
    Staff

    colormecnblue, please stop replying in multiple threads.

    You don’t need to disable Adblock completely, just report the issue to Adblock and whitelist our site as detailed above.

    #914295

    windwhistle
    Member

    Disabling AdBlock on my blog seems to have fixed the problem. Not something I should have to do. It seems to me that if neither I nor AdBlock made any changes, then the problem likely was caused by some of WP’s constant tinkering …

    #914296

    tsunderetan
    Member

    I disabled the adblock on my blog in firefox and that seems to have solved the issue as well. I don’t believe this is an Adblock issue but a wordpress issue though. I hope the admins are looking into this. At least I didn’t have to completely disable the entire adblock plugin but it’s still frustrating.

    #914297

    timethief
    Member

    @windwhistle
    @tsunderetan
    As I understand it this is not an AdBlock issue. Adblock blocks ads and blocking is limited to removing advertisements that are technically not part of the web page but downloaded separately.

    #914298

    inkophile
    Member

    This issue has been going on for two days since I updated Fireflox. Adblock was the issue but you only need to disable it on WordPress to make things right.

    From any admin page on your blog select Tools > Adblock Plus > Disable on (name of your blog). Reload the page and you will be able to edit posts, see stats, etc.

    Adblock will continue to block ads on other sites and hopefully will correct its white list deficiency ASAP.

    #914301

    inkophile
    Member

    Submitted a report to Adblock that diagnosed a “false positive” issue. No indication when it will be resolved.

    #914307

    macmanx
    Staff

    inkophile, thank you for helping to clarify that and sending in a report!

    #914325

    macmanx
    Staff

    This should be fixed now, so please feel free to try again. If you disabled Adblock to get around this, you should be able to safely re-enable it now.

    #914334

    windwhistle
    Member

    I re-enabled Adblock on my blog. The problem with the visual editor returned. Went in and disabled Adblock again. This time the disable did not fix the visual editor problem. So now I’m stuck with a useless visual editor and no way to write new posts or edit old ones. (And yes, every change I’ve made has been accompanied with cache clearing and computer restart.)

    #914336

    windwhistle
    Member

    I just turned Adblock off completely, and the visual editor started working again. However, I don’t consider this an acceptable solution. I still think the problem is with WP.

    #914337

    simplersjoy
    Member

    I also had problem noted here https://en.forums.wordpress.com/topic/currently-unable-to-edit-posts-or-see-toolbar?replies=1 and solved it by disabling Adblock. Thank you for help

    #914346

    macmanx
    Staff

    windwhistle, we made another slight change just now. Please try again after clearing your browser’s cache.

    #914350

    windwhistle
    Member

    I re-enabled Adblock, emptied caches, exited Firefox, and restarted computer. Now if I try to edit an existing post, I’m taken to the HTML screen, where text appears. If I switch to visual editor, text is gone. Toolbar at top of window only show 3 icons, whether I try to edit old post or enter new one. Still looks broken to me.

    #914351

    macmanx
    Staff

    Would you mind removing us from the whitelist, then look at blockable resources when you load the page and can hover over the URL that was blocked (like maybe http://s0.wp.com/….)? It will provide some detail as to why it was blocked, and that would be a big help to us.

    Of course, you’re welcome to whitelist us again after that. :)

    #914354

    windwhistle
    Member

    Don’t know my way around Adblock very well. The full address of the item that was blocked appears to be:

    https://s0.wp.com/_static/??/wp-includes/js/jquery/jquery.js,/wp-content/mu-plugins/subscriptions/follow.js,/wp-admin/js/utils.js,/wp-admin/js/blog-switch.js,/wp-content/admin-plugins/post-ads/post-promos.js,/wp-includes/js/spin.js,/wp-includes/js/jquery/jquery.spin.js,/wp-content/admin-plugins/after-the-deadline/atd.core.js,/wp-includes/js/quicktags.js,/wp-content/admin-plugins/after-the-deadline/atd-nonvis-editor-plugin.js,/wp-content/admin-plugins/after-the-deadline/jquery.atd.js?m=1339564511j

    Is this the info you’re looking for?

    #914356

    Good morning: I can´t edit one draft since this morning. When I recover it and try to edit from the visual editor, this shows empty and It doesn´t let me write a line. I emptied the cache and tried at Chrome and Firefox and my problem is still there. I didn´t had already Adblock at my computer so I can´t understand very well what it is going on… I would appreciate very much any help. Thanks.

    #914357

    macmanx
    Staff

    windwhistle, that’s great, definitely the source, we just need the cause. Would you please hover over that portion of the blocked scripts and tell us the “filter in effect” for that URL?

    anchoasytigretones, please try enabling HTTPS to see if that makes a difference: http://en.support.wordpress.com/https/

    #914358

    Thank you very much for your support and for the fast answer. My blog seems to work properly now. (It was the https issue you mentioned). Thank you, again.

    #914359

    YES: Enabling HTTPS (see post macmanx 11:07) works for me! I tried editing posts on two machines, both same Chrome version, on the first it was working, on the second not. But now it does, after enabling HTTPS (which was already enabled on the other machine)

    Thanks a lot

    #914367

    windwhistle
    Member

    macmanx, the filter in effect at that position is -ads/

The topic ‘Why can't I see the visual editor?’ is closed to new replies.