Why do my images disappear when I hit 'save draft'?

  • Author
    Posts
  • #1011410

    If you can see 1 ‘BOLG’ thingy, then you should be seeing a dozen or so because I keep calling in another one when I try something and every time, when I click ‘Save Draft,’ it (and any other pic I try) goes away. As the screen refreshes, the pic is there for a second, but disappears.

    Can you try closing all the tabs in your browser, then quit and restart Firefox?

    How is it you can see an unpublished screen with pics on it that I can’t see?

    I can only see one one image inserted.

    #1011411

    Well, since this problem cropped up on the 13th, I’ve shut down the computer for the night every night since then (and Firefox – and the tabs – all shut down when the rest of the computer shuts down). So, I’ve completely shut down at least 5 times since this cropped up.

    Some days, because of resources issues, I restart during the day, too, so I’ve completely shut down MORE than 5 times since this cropped up.

    I just checked, it’s still dumping the pics when I hit ‘Save Draft.’

    #1011412

    Okay. After you insert the images into the post with the Add Media button, can you switch to the Text editor, select all the text, copy and paste it into a text file? (Save that to your desktop for safe keeping, in case your changes aren’t being saved.)

    Then, please take two screenshots and upload both to your Media Library:

    1. What you see in your browser window before you click Save Draft
    2. What you see after you click Save Draft

    Also, can you let me know if you get the same result as before in an alternate browser, such as Google Chrome?

    #1011413

    1) ‘before’ and ‘after’ are in my media library.

    2) I don’t have another browser on board. Firefox has worked for over 2.5 years. Why would it suddenly become the problem? I have a WP.org site up and running now, and have loaded dozens of pics onto the site so it’s not Firefox.

    #1011414

    This post isn’t complete … when I started having the problem, I stopped working on it.

    #1011415

    ‘before’ and ‘after’ are in my media library.

    Those screenshots are when previewing the post. Can you take the screenshots from your dashboard in the text editor?

    I don’t have another browser on board. Firefox has worked for over 2.5 years. Why would it suddenly become the problem?

    I’m not sure, and that’s what I aim to find out.

    For what it’s worth, I was successful in saving a draft on my WordPress.com blog in Firefox 15.0.1 and the draft saved the post and the existing image inserted from my Media Library.

    You can download Google Chrome here:

    http://browsehappy.com/

    or here:

    https://www.google.com/chrome/

    #1011416

    The screen shots are from the text editor in the dashboard. I have 2 choices – plain English or gobble-d-guck. So, I use plain English. I don’t know of any other way to do this. It’s the way I’ve used it since starting this blog in late 2009. I don’t even have the remote post creation stuff engaged – I use the dashboard – always have.

    I’m using the latest Firefox.

    If you saved the screen shot, of course you were able to ‘save’ the pics. They’re all one piece. I use Snag-It for screen shots.

    Is it really necessary for me go gobble up a big pile of resources with another browser? What about the learning curve. I need this post to be complete and scheduled before bedtime tomorrow. With everything going on right now, I really don’t have time to teach myself another browser right now. Since I have another WP running and working fine, it’s a pretty safe bet it’s not Firefox, esp. since it’s the same version you’re using.

    #1011417

    The screen shots are from the text editor in the dashboard.

    I’m seeing the before.jpg and after.jpg screenshots, but they aren’t from the Text editor on the Edit Post screen.

    I’ve uploaded a screenshot to your Media Library that shows how the Edit Post screen looks. (I would’ve linked to it here, but I know you want to keep that announcement under wraps until Thursday.)

    In case it might have to do with an add-on or setting, can you try Firefox in Safe Mode?

    In the Firefox Help menu, click “Restart with Add-ons Disabled”.

    Is it really necessary for me go gobble up a big pile of resources with another browser?

    To help us get to the bottom of this Firefox issue (post drafts not being saved) that I’m currently unable to reproduce, yes.

    Short of installing the browser and logging into your WordPress.com account at the top of http://wordpress.com/ , navigating to your WordPress.com blog dashboard is the same.

    #1011418

    OK, I’m not a techie. Firefox in the safe mode? Never heard of it.

    I haven’t added any new add-ons in months so I doubt it’s an add-on. Every time Firefox comes out with a new version I LOOSE add-ons!

    Doing the restart Firefox now – have to send this, or lose it.

    The text on the screen is being saved. I’ve had that same text on the screen since the beginning – I’m not rekeyboarding it every morning when I fire up. It’s only the PICTURES that are disappearing!!!

    I’m in the screen you’re saying I have to be in. I didn’t know there was anyplace else I could be … see the pic I put in the library. (It is big because I’m 64 and need things larger than the younger folks!)

    #1011419

    UM … the pics are there … so, it’s an add-on, even though I haven’t added any new ones in months. As I said, when Firefox goes to a new version, I LOOSE add-ons, so how can this happen?

    #1011420

    So … now what do I do?

    How do I turn on the add-ons again (including the ability to make things big enough for me to SEE them)? That entry in the Help pulldown is not a toggle – it still says the same thing.

    Which add-on is it? How do I figure that out?

    #1011421

    Well, it’s bedtime for me.

    I’ll check back when I get up to see if the answers to my questions are here.

    How could this have happened if I haven’t added add-ons in months?

    How do I get my add-ons to work again? ‘Restart with add-ons disabled…’ is not a toggle, so how do I turn them back on?

    How do I figure out which add-on is doing this?

    Why did you disappear when you did?

    Julie

    #1011425

    the pics are there … so, it’s an add-on

    Hi Julie, I’m glad we’ve narrowed that down. Thanks for trying Firefox in Safe Mode. :-)

    How do I turn on the add-ons again (including the ability to make things big enough for me to SEE them)?

    You can quit Firefox completely, then open Firefox again and it’ll start in regular mode.

    Which add-on is it? How do I figure that out?

    1. After you’ve quit and reopened Firefox, go to Tools -> Add-ons.
    2. Disable all add-ons.
    3. While viewing the Edit Post screen in your dashboard in one browser tab, and the Add-ons Manager in another tab, enable one add-on at a time, making sure to refresh your Edit Post screen between enabling add-ons.

    How could this have happened if I haven’t added add-ons in months?

    I’m not sure. Perhaps the developer of one of the add-ons installed in your browser introduced a feature or bug fix that changed how (if) images are displayed in WordPress.com.

    Why did you disappear when you did?

    To eat dinner and spend time with my wife. :-)

    #1011426

    Hi again,

    First, thanks for all your help. I really do appreciate it.

    Second, ‘gotcha’ on narrowing down the exact add-on. I’m really busy so what I may have to do is disable the whole bit again like we did last night and do the post (I haven’t touched anything since last night. I didn’t dare. So, it’s now 3 PM here, and I have to get this post done sooner rather than later.

    I may have time to do the narrowing down of the add-ons tomorrow. For the moment, I’ll leave the issue open, pending getting through that without a self-destruct happening. You never know when I’m involved.

    And, I apologize for the ‘disappearing’ comment. It’s just that the timing was bad. Suddenly, we have a solution and suddenly you’re gone – sorta like, ‘OK, that one’s fixed. Next?’ I should have known, and I’m sorry, really.

    So, I’ve got a post to finish for tomorrow.

    Again, thanks for your help. I never in a million years would have guessed a Firefox add-on would be the culprit, esp. since I haven’t added any in ages!

    Have a good one.

    Julie

    #1011427

    You’re welcome, Julie!

    Please let me know if you’re able to find the Firefox add-on that’s causing the issue by replying to this forum thread since it might help others in the future.

    I may have to […] disable the whole bit again like we did last night

    Another alternative is to disable the add-ons that you can live without (for now). Otherwise, you can just disable all add-ons while using Firefox in regular mode (instead of using Firefox in Safe Mode).

    I apologize for the ‘disappearing’ comment. […] I should have known

    No apologies are necessary. :-)

    Cheers!

    #1011428

    Interesting …
    Here’s what I did –
    I set up an add-ons tab next to the tab with the WP Edit screen, which had the post that had been so problematic on the screen. At the time, no pics were showing, nor was space allotted for them, but 4 pictures were in place (and published with the post).
    Starting at the top of the list of add-ons, I disabled one, then switched and refreshed the Edit Screen. If there was no change, I went back and enabled that add-on. When I’d done a screen of add-ons in that manner, I restarted Firefox. I did 24 add-ons in this manner.
    When I got to Firefox’s Personas 1.6.2, the pictures appeared when I refreshed. I was surprised, needless to say.
    Then, I tried everything to reproduce the situation, but now, the pictures are ‘stuck’ there, in place and visible. Because the post is published, clicking on ‘save draft’ isn’t an option, but, last night, when I clicked ‘publish’ to schedule the post, the pictures went away (as they’d done with ‘save draft’ before) and didn’t publish, so I did the ‘restart with add-ons disabled’ trick and re-scheduled the post.
    When I clicked ‘publish’ again, the pictures held.
    So, disabling Personas put the pictures on the screen. Logically, enabling Personas again should have taken the pictures out but it didn’t. They now won’t go away – I clicked on ‘update’ several times (which made the pics go away last night), and I even restarted the computer! I can’t check the rest of my add-ons because now I can’t make the pictures go away!
    My results, therefore, are inconclusive, especially since I have a WP.org sharing Firefox that never displayed the same problem as this WP.com site.

    #1011429

    Thanks for following up here. The combination of enabled add-ons might have caused the inconsistency, but it’s tough to say.

    When writing your next post at WordPress.com, can you try disabling all Firefox add-ons (except for Personas Plus) to see if you get the same result with adding images and having them displayed in the Visual editor of the Edit Post screen?

    If you’re interested, you can copy the text of the post you’ve just published into a new post draft. With the Add Media button, you can insert the images that you’ve already uploaded from the Media Library tab. (In other words, you don’t need to reupload the images.)

    #1011431

    Well, if I ever do another post on that site … the post that went up today is the last one, as far as I know. I’ve moved to a .org site.

    I never reloaded pics, except in one circumstance. I used pics conservatively, so I’ve only got 23 pages of pics in storage on the .com site. I had to reload the ‘blog’ pic I used on almost every post several times because it got lost in the pages of pics and was really hard to find, so I reloaded it to bring it up front.

    FYI: It would be so great to be able to alphabetize the pics to find them easier.
    It would also be great to be able to move the pic on the edit screen rather than having to kill it and reload it in a another space. Sometimes you forget to click on the proper one of the left-center-right buttons and the pic shows up in the wrong place. Now, you have to kill it and reload it cuz it won’t move.
    Just a couple of ideas for your designers. I’m a retired typesetter/print shop owner (and proficient in Adobe InDesign, among other programs) so you can imagine how limited this system is to me.

    #1011432

    Thanks for your helpful feedback. If you have any other ideas for WordPress.com, please feel free to post your suggestions in the Ideas forum:

    https://en.forums.wordpress.com/forum/ideas

The topic ‘Why do my images disappear when I hit 'save draft'?’ is closed to new replies.