Why does my blog link show as private when it is public?

  • Author
  • #648900

    I have tried to post a link to my blog on Facebook numerous times and the link shows that this is a private blog. My account settings are set to public. I have tried to change to private and back to public (as suggested in forum) to no avail. How can I fix this?
    Blog url: http://lorishields.wordpress.com/



    Lori, hi! We’ll sort you out. We may need just a couple more details to help us get to the bottom of this.

    Can you walk me through exactly where you’re posting the address on Facebook? How are you doing this? What’s the exact error message you see, and what’s the exact link you’re posting?


    Hi. Thanks for your response. I am on Facebook wall or newsfeed and clicking on “link”. I type the url: lorishields.wordpress.com and receive the following error:

    Protected Blog › Login

    http://lorishields.wordpress.com/ is marked private by its owner. If you were invited to view this site, please log in below. Read more about privacy settings.

    I had someone else try to post a link on their page and same error occurred. Thanks so much.


    Hmm, the site at http://lorishields.wordpress.com/ is loading without the privacy warning for me right now. What happens if you click that URL from this page?

    Could you make a screenshot of the warning you see an upload it to your site? Thanks!


    I have a screenshot but how do I attach it to this thread?

    Your link works fine, it’s when I am trying to share the link on my Facebook page that I am having the error



    Facebook has been know to have some odd caching issues from time to time. Ask another friend to share a post from your blog. This may kick FB into gear.

    As for the screenshot, please upload it to your Media library via Media -> Add New in your blog’s Dashboard.


    Ok, macmanx, that solved the problem. Thanks so much for your help.



    You’re welcome!

The topic ‘Why does my blog link show as private when it is public?’ is closed to new replies.