Why does WordPress Reader send me comment notifications when they are turned off

  • Author
  • #1294968


    In my WordPress reader, it says I have the “comments” feature turned off of this one blog, but I still get tons of comment posts in my reader from that one blog, even though I haven’t commented on the post they belong to.

    Any help or advice would be much appreciated!

    The blog I need help with is kyliebyrd.wordpress.com.



    Hey, just wanted to clarify that it’s not my own blog I’m struggling with, it’s the WordPress reader. That bit at the bottom of my original post was automatically added or I didn’t notice it.


    1. Have you tried clicking the “unsubscribe” link at the bottom of the comment emails you receive?

    2. Have you tried visiting the post you subscribed to receive comments from and clicking that same button again to unsubscribe?



    Thanks for your response!

    1. I don’t receive comment emails, I just get a queue of comments in my WordPress Reader on WordPress.com. Under “Blogs I Follow,” where I’m supposed to only get updates for posts, I have a long queue of comments to this one blog.

    2. I’ve never commented on the blog or subscribed to receive comments from it, but I did go to the comment section of the blog after your suggestion to see if there was an unsubscribe option. The option “don’t subscribe” to comments was already activated.

    Thanks again for your time.


    I have the same issue Kylie…it really annoys me and to be honest, I hardly log into wordpress anymore because of it. If I wanted to look at the comments I would look at the comments, I don’t even know when new posts are posted, because theres 50 comments on who knows what before theres an actually post from any 1 blog in my reader. Would LOVE to know how to just see blog posts and not all the comments.



    I’ll tag this thread for Staff investigation and response. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.



    @kyliebyrd and @algenina – can you go to this page and check whether or not you have anything listed?

    This page shows the list of blogs you have chosen to follow all comments – meaning when a new comment is posted to those blogs, you will be notified via email. You can also remove any blog comments feed from this same page.

    In addition, in the email notification you receive there should be a link to unsubscribe from those comments.

    Please check the page I linked to above and let me know if you still have trouble.




    Thanks for looking into this, timethief and csonnek. I’ll try to explain what my circumstances are:
    I looked into that link, and did not see the blog on there that was filling up my WP Reader with comments. However, I actually unsubscribed to the blog on my reader to prevent the comment glitch from happening. Then, once I grew tired of manually checking the blog for updates, I re-added it to my Reader, crossing my fingers that the comment spam wouldn’t happen again. It hasn’t! I’m not sure what any of this means.



    @kyliebyrd – I’m glad that somehow fixed it for you!

    If it happens again – please don’t delete/unsubscribe the blog that you’re receiving comment notifications from in the Reader. That way we will have something to look at and see if we can figure out why it’s happening for you.

    In the meantime, let me know if I can help you with anything else.


    I’m having this same problem with reader. The reader is filled up with comments from just one blog I follow and there are so many that it’s bumping all of the actual articles I might want to read off my reader. I’m going to try unsubscribing and resubscribing I guess- but it’s really annoying and it didn’t used to do this. :(



    @adventurelaura – did unsubscribing/resubscribing work?

    Also, can you give me a link to the blog that you’re receiving comments in your Reader feed so I can take a closer look?

    Thank you!


    yep! I guess it’s actually 2 blogs filling my feed up with comments-
    http://trexrunner.com/ < actual blog for the first one
    http://abetteryeartoabetterlife.com/ < that’s the actual blog for the second one

    I don’t think unsubscribe worked. I tried it with TRex Runner- but I also resubscribed in just a minute or two. Wonder if I should unsubscribe overnight or something.



    @adventurelaura: thank you for that information! That helps a lot.

    I can confirm you’re only following those sites, yet you’re still getting the comments for those sites in your feed. Can you keep both of those sites in your Reader feed without unsubscribing and resubscribing to them? I’m going to have one of our developers take a look to see what might be going on and since I’ve verified that it’s happening in your feed, it will help them as they try to narrow down the problem.

    I’ll be back in touch with all of you once I have more information from our development team.

    Thank you!


    @csonnek as long as I’ve got the ear of a tech person- I have an unrelated question about separating my two blogs (I want a second person to have access to one but not the other… so I’d rather just transfer the second site to different login/email etc.) Is there somewhere I can email you with the details? I’d sure appreciate it! <3 WordPress!



    @adventurelaura: could you please start a new thread, describe your issue in detail, and add the word modlook in the Tags section in the right column so a member of Staff will respond.

    Thank you!



    I am spontaneously having the same trouble with the same blog again! The blog in question is http://www.documentingdelight.com. Just thought you should know in case you are still investigating the bug.

    Thanks very much for all your help.



    Hi Kylie – thanks very much. I see that they are there, and I’ve updated the report with your specific information. :)



    Hi all,

    This has started happening to me today too.

    I have all of my followed blogs (except for one) set up so that I receive no post and no comment emails on all of them. I choose just to have any new post show up only in my reader.
    I have clicked on the link (that csonnek advised above) to show if I am following any comments and it tells me that I am not.

    The blog that is showing up comments in my reader is a blog I follow, but I have not followed any of the specific posts comments that are coming up.
    The blog that I am receiving these comments on is mintedmoose.net

    I have not tried the unsubscribe and resubscribe option – I would prefer to wait to hear from someone at WordPress if there is a slight glitch that needs fixing.

    I look forward to hearing from you guys and hope you can help me too.



    Hi, I am also having this problem. My Reader is filled with comments on blogs that I follow. It takes a lot of scrolling to actually get to the original posts; this is very annoying and frustrating. I have it set up so that I don’t receive post or comment emails on all of the blogs I follow. Is there a way to control the content in my Reader so I can eliminate comments and just read the posts? Is this the way WordPress is supposed to work?

The topic ‘Why does WordPress Reader send me comment notifications when they are turned off’ is closed to new replies.