Need help? Check out our Support site, then

Why doesn't my Jetpack Site Stats no longer load?

  1. I added site stats to my jetpack configuration, its worked great for a few months. Now when I try and load the stats all that shows up is the "w" (wordpress logo) with a rotating loading status. I've left it for as long as 30 minutes but nothing ever shows up.

    Please help!

    The blog I need help with is

  2. Do you also encounter this issue in a different browser? for example Safari or Google Chrome?

    Otherwise please try clearing out your cache.

  3. Yes I encounter this issue on Safari as well.. I've tried cleaning out my cache and I still encounter the same problem. I've updated to the current jetpack version

  4. Could you send us a screenshot of the page where you're seeing this? You can upload the screenshot to your blog's media library and post the link of the file in this thread.

    Sorry for the inconvenience.

  5. Could you try to disable all other plugins and reactivate Jetpack. This way we can see if other plugins interfere with Jetpack.

    Also make sure you are running the latest WordPress and Jetpack version:

    Looking forward to your reply.

  6. It worked, thanks!

  7. You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.