Why don't my pages show up?

  • Author
  • #806558


    I’m using the Chateau theme and apparently can have additional pages. I’ve created an ‘About’ page and ticked the box in “all pages” but it doesn’t show up on my blog. I’m obviously doing something stupid – but what?! Thanks.

    The blog I need help with is noelinesmith.wordpress.com.


    Ticking the boxes in Pages > All Pages is only for selecting multiple pages in order to bulk edit them, not for activating the pages. When you publish a static page, you automatically get a tab for it in the header area, except if a custom menu has been activated (you were probably using a different theme and switched to Chateau). Go to Appearance > Menus, select the blank option from the pulldown in the Theme Locations module, save.



    You’re right – I changed theme …..
    Sorted out now though. Thanks very much – once again!


    You’re welcome!
    If you want a Home tab as well, you’ll need to create and activate a custom menu – see here:



    That’s great – thanks (and now I understand how ‘categories’ should be used!)

    I don’t want a sidebar so would like to have a top drop down menu for archives ie. Archive – Jan 2012, Feb 2012 etc. I understand now I need to categorise my posts as ‘Jan 2012’ etc. and how to create the menu with drop downs (I think!).
    So, my question is, is it possible to make the front blog page show only the current month? If so, how do I then archive the January front page when we get to February?

    Thank you.


    Your theme supports footer widgets as well: you can go to Appearance > Widgets and add the Archives widget to a footer widget area.

    But if you don’t like that and want a dropdown of monthly archives, you don’t need to categorize your posts the way yo say: they are already sortable by month. The URL for all posts published January 2012, for example, is this:
    So you can create a custom menu and add those URLs as custom links.

    You cannot directly make the blog front display the current month’s posts. But you can set the number of posts per page in Settings > Reading.



    Once again – thank you very much. As soon as I have blogged enough to bother with an archive (!) I’ll have a go. Hopefully by that time I’ll have got my head around things a bit better and won’t raise silly questions!


    You’re welcome, and your questions aren’t silly.

The topic ‘Why don't my pages show up?’ is closed to new replies.