Why has my "add media" button stopped working?

  • Author
  • #1471438

    After posting over 40 blogs, my “add media” button won’t work. I click on it to insert a photo into my blog, and nothing happens.

    The blog I need help with is laurenlinwood.wordpress.com.



    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) And what any error reports you receive state.


    Actions taken:
    -updated browser (Google Chrome) through browse happy
    -caches cleaned
    -3rd party cookies / Java already enabled
    -added to my trusted sites
    -tried Internet Explorer as a different browers

    None of these changed the fact that add media doesn’t work (plus I can no longer set the date/time when to post).

    I’m using an HP w/Windows 7 and ie 10 browser. No error reports have come through.



    Thanks for posting your details I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.



    Hi there,

    You mentioned that you have Java enabled. Do you also have Javascript enabled? If you aren’t sure, you can check that here: http://supportdetails.com/

    Javascript is required for certain features to work properly. If you have Javascript enabled, please also try adding Gravatar.com as a trusted site. Gravatar is part of the WordPress.com network, and blocking Gravatar.com may cause problems on certain pages at WordPress.com.

    If you continue to have trouble with this, please let me know!


    Sorry – I was typing fast and just shortened it to Java – but I do have JavaScript enabled and added the Gravatar.com to the trusted sites.

    Still won’t let me insert a pic (It says 0% and doesn’t budge) or select a time to post. Or even “like” another WP blog that’s been posted.

    It just puzzles me since I began the blog in February and never had any troubles before. Haven’t changed computers. Walked through all the above suggestions. Can’t figure out why it would start this out of the blue!



    How much space in your media library are you using? Someone else had this problem and their media library was full, because they were uploading full size, full resolution photos.


    Are we talking my personal media library or library on WP? I have very few pix in the WP gallery.

    If it’s my library, where do I locate the indicator for how much space is being used? Thanks!



    Hi there,

    You mentioned that you updated Google Chrome and tried using Internet Explorer 10. Are you still having trouble with this in both browsers?

    Also, can you double-check to make sure that compatibility view isn’t turned on in Internet Explorer? You can find instructions for turning it off here:



    I’ve finally just taken IE 10 off my toolbar. If I avoid it and go in using Chrome, I’ve finally been able to insert a picture!

    Still don’t know why this would happen since I’ve been posting from back in February!

    Thanks so much for spending so much time helping me to solve my problem! I just had a new book released yesterday, and my blog is my lifeline. Gotta have pictures on it!

The topic ‘Why has my "add media" button stopped working?’ is closed to new replies.