Why is Posterous import .xml file not recognised ?

  • Author
    Posts
  • #1212345

    kewcottages
    Member

    During TOOLS|POSTEROUS IMPORT when I upload the posterous .xml file “wordpress_export_1.xml”
    I get
    Sorry, there has been an error
    The file is not an xml file. Please see instructions for downloading and using the Posterous backup file.”

    The blog I need help with is kewcottages.wordpress.com.

    #1212469

    timethief
    Member

    That is not an XML file. It is a zip file. Please consult this guide http://en.support.wordpress.com/import/import-from-posterous/
    I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

    #1212483

    kathrynwp
    Staff

    It looks like your computer may have added a .txt extension to the end of the export file.

    Could you please try removing that .txt bit and make sure only the .xml extension is present, before trying another import?

    Please let me know how it goes.

    #1212498

    kewcottages
    Member

    Thanks for your suggestion Kathryn,

    However, there is no evidence that .txt has been added to the name.

    I will email the .xml file to you for you to check if you give me an address to send it to..

    Regards,

    Kew

    #1212532

    kathrynwp
    Staff

    Sure, I’ve sent you an email to which you can reply with your file attachment.

    #1212553

    kewcottages
    Member

    Hi Kathryn,

    I have sent you two .xml files (old and new ex Posterous) as you requested. However, both files receive the same error when I upload them to WordPress.

    Have you checked the second file yet please ?

    Kew

    #1212554

    Others have had success with this issue by using a new browser, like Firefox or Chrome. Hopefully that works

    #1212555

    kathrynwp
    Staff

    Hi there, thanks for following up. I didn’t receive the second file, only the first, which had the technical issues I mentioned.

    Would you mind replying to my original message again, attaching the second file? Please be sure to keep the subject line intact – including the ticket number – so the message will come to me. Thanks very much.

    #1212556

    kewcottages
    Member

    Thanks Daniel and Kathryn,

    The browser I used (Safari ) does appear to be an issue.

    I have now tried Chrome and get a different error message ie:

    “Import Posterous
    Sorry, there has been an error.
    The file does not exist, please try again.

    Processing…

    We’re processing your import now and will send you an email when it’s all done. If you don’t hear from us within 24 hours, please contact support, and we’ll get everything fixed.”

    That is ambivalent, but hopefully it is actually processing now.

    Can you check and let me know please Kathryn ?

    In the meantime I’ll email you another copy of the new .xml file to check.

    Thanks again Daniel :-)

    #1212557

    kewcottages
    Member

    Chrome did work ok … :-)

    WordPress.com has just confirmed

    “Your WordPress content import for http://kewcottages.wordpress.com was successful.”

    So thank you both.

    Are you aware of any other browser related problems like this with WordPress ?

    #1212558

    kathrynwp
    Staff

    Thanks for letting me know – I’m glad it worked.

    I spoke with our developers and we’re not currently aware of any Posterous import problems in Safari, but I’d like to test it. I haven’t yet received your second file, but I’ll run a test with someone else’s Posterous import file and see what happens.

    #1212560

    kathrynwp
    Staff

    I was just able to do a test Posterous import fine in Safari, so there may have been something particular about your export file that was causing a glitch.

    I noticed that some of your images didn’t get imported from Posterous and are still being pulled in from there. I’m going to ask our developers to fix that up – I’ll keep you posted.

    #1212565

    kathrynwp
    Staff

    Thanks for the new file. I was able to replicate the import problem in Safari and am going to bring it to our developers so they can investigate. I was able to upload the same file into a test site in Firefox. Thanks for bringing this to our attention.

    In the meantime, could you please leave your Posterous site intact, until we’ve been able to fix up all your image imports? Thanks.

    #1212566

    lizpanton
    Member

    Please feel free to move this comment elsewhere if you consider this to be “hijacking”:

    Just to report another Posterous import problem in the last few days in case it is related – using Firefox 20 on Mac 10.5.7 (Lion).

    My import of the XML file worked partially. It was a very small blog. Not all text imported and only one of the four images on the blog.

    I do not know whether the problem was with the XML exported or a problem with the import process.

    As it is just a small blog, I copied and pasted to rebuild it on WordPress.com and did not bother to report it as a problem.

    I have exported blogs from Posterous and then imported to WordPress.com with lots of posts and images in the past with no problems.

    A bit of a heads up:

    – look at your WordPress.com content in “text” view for any posts or pages that have media embedded, to check that the media have actually been imported.

    – Media that are unsupported in WordPress.com, like audio and video, might appear to have been “imported” but they will just be in links to media that is still embedded back on Posterous – so will fail when Posterous closes at the end of the month. (My audio files disappeared off Posterous a long time ago and I had to upload them elsewhere and re-link to them on my free WordPress.com sites).

    – pdf files are embedded on Posterous via Scibd. I replaced all these embeds as I wondered if they might disappear too, even if they are still saved somewhere on Scribd.

    Hope this is helpful,
    Best wishes,
    Liz

    #1212567

    kathrynwp
    Staff

    lizpanton – I would be very glad to help with your issue, but we can’t move individual posts within a thread, so could you please start a new one? Add the modlook tag so Staff will respond. Thanks.

    #1212570

    lizpanton
    Member

    Thanks @kathrynwp – it is OK – I don’t think there are any problems left to be fixed on my blogs.

    I was just hoping to add some information that you and @kewcottages might find helpful.

    The general issues about content apparently imported but actually remaining embedded on Posterous applied to all the blogs I have imported over the last year, so this might be a routine feature of the import process. I only noticed it by chance and should really have brought it to someone’s attention at the time.

    I will start a new thread so the issue is flagged up more obviously :-)

    Best wishes,
    Liz

    #1212571

    kathrynwp
    Staff

    kewcottages – we’ve run a script to fix most of the images on your site that were still pointing to Posterous.

    These posts still had content/links pointing back to Posterous and will need to be fixed manually:

    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=830932
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=958103
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=10692484
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=10782105
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=12580354
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=13181893
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=15015264
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=15282918
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=26630015
    https://kewcottages.wordpress.com/wp-admin/post.php?action=edit&post=111050213

    In terms of the Safari import issue, since we haven’t had any other reports, and since your import is now completed, we won’t be investigating further for now. If we get reports that this is affecting others, we will definitely look into pursuing a solution.

    Best of luck with your new site. Let us know if there’s anything else we can do.

    #1212572

    But Kathryn there are numerous forum posts from people saying that the import is unsuccessful because an error comes up saying this is not an .xml file, and people have found changing browser helps, or have emailed in the file for staff to compete. So it looks like there may actually be an issue. A quick forum search will show that.

The topic ‘Why is Posterous import .xml file not recognised ?’ is closed to new replies.