Need help? Check out our Support site, then

Why isn't my post publishing?

  1. corporatespeechsolutions

    This past week I've tried to post my blog several times. Each time I click "Publish", it changes to "Publishing", but it never actually publishes. It remains in the "Publishing" phase indefinitely. I've tried just letting it go for up to an hour, and no luck. Has anyone else ecountered this problem? I've been posting for over a year and never had any difficulty.
    Blog url:

  2. Dozens and dozens of people are reporting this lately. What browser and version are you using? Are you using the New Post button in the Admin bar or Dashboard->Posts->Add New?

  3. corporatespeechsolutions

    I actually just posted successfully by going through the Dashboard. The issues is happening when I try to use the New Post button directly from the home page. I'm using Internet Explorer, not sure which version. Going to give it a shot with Chrome next time and see if that helps.

  4. Right, NEVER use that button. There are all kinds of problems with it.

  5. I'm using Internet Explorer, not sure which version.

    This isn't a browser related issue. There's an issue with creating posts on the front page of that will not be fixed until the next upgrade. Do not create posts here >!/post/

    Instead raincoaster and I and all Volunteers recommend that you ONLY create posts here > Dashboard > Posts > All Posts > Add New

Topic Closed

This topic has been closed to new replies.

About this Topic