Widget adding wipes out sidebar

  • Author
    Posts
  • #564582

    theocentrist
    Member

    Hey folks,

    I have a default sidebar with links, post archive, etc. But I wanted to add a few more things I didn’t have (widgets). But when I drag and save a widget to the sidebar tab, then look at my website, the whole sidebar links have been deleted except for the widget I added. When I take the widget off, everything is back to normal.

    How do I add widgets to the sidebar, rather than replace everything?

    The blog I need help with is theocentrist.wordpress.com.

    #564690
    #564694

    mrbisogno
    Member

    The same thing just happened to me. I added a text widget which showed up in the right sidebar, but everything else disappeared. When I go to my dashboard/links, they’re all there and shows that they are visible. Damn, I was having a good day too!

    #564696

    Did you bother to read the linked post @panos provided? It has your answer.

    #564699

    mrbisogno
    Member

    This WordPress support pages says nothing about losing everything when you add a widget.

    http://en.support.wordpress.com/prevent-content-theft/

    #564700

    I expect you pasted the wrong link.

    #564701

    mrbisogno
    Member

    I went to that link and I’m on it now. Thanks.

    #564702

    In this support page titled “widgets”

    http://en.support.wordpress.com/widgets/

    It says this under “Default Widgets” ( http://en.support.wordpress.com/widgets/#default-widgets ):

    If you haven’t added any widgets to your sidebars, the theme will show a default set of widgets, which will not be listed in the Sidebar area.

    When you add widgets to a sidebar the default set of widgets will no longer be used. Try adding a blank Text Widget if you don’t want anything to show up in a widget area.

    #564703

    timethief
    Member

    When we changes themes all widgets in use migrate for easy location into the Inactive Widgets box. Each theme displays a default set of “sidebar display” generated from the theme’s underlying files. As it’s a sidebar display and not actual widgets you will not be able to find them here Appearance > Widgets and physically remove them.

    What happens is that when you go here Appearance > Widgets and select the widgets of your choice, drag them out of the Available widgets box and drop them into the sidebar(s) box(es), your choices of widgets and your placement of them will overide ie. cancel the “sidebar display”.

    This isn’t a big deal. Simply go to the Inactive Widgets box and drag and drop widgets widgets into place in the sidebar.

    #564711

    mrbisogno
    Member

    Thanks everyone for all the help. The first thing I always do when something like this occurs is hit the panic button!!! I took a few deep breaths and went to Appearance/Widgets and everything is back to normal again.

    #564716

    mrbisogno
    Member

    timethief,

    While I have your attention, there is something I have always wanted to ask you so here goes: How did you replace the WordPress emblem in the URL field at the top of the browser window with your lovely image? I would like to do that with my…er…image. Thanks!

    #564717

    1tess
    Moderator Emeritus

    Not timethief, but you are talking about inserting a blavatar:
    http://en.support.wordpress.com/avatars/blavatars/

    #564720

    mrbisogno
    Member

    Yes, I guess you’re right. I have a blavatar, the one next to my name in this post, but it doesn’t show up in my browser window or tabs. Maybe because I’m using http://Blog-Bisogno.com rather than http://blogbisogno.wordpress.com/?

    #564721

    1tess
    Moderator Emeritus
    #564722

    mrbisogno
    Member

    1tess, I forgot to mention that I went to the link you provided, but I did all that. It never migrated to my tabs and browser window.

    #564723

    mrbisogno
    Member

    Thanks!

    #564724

    1tess
    Moderator Emeritus

    You are welcome:
    it looks like it’s working now!
    ?
    Tess

    #564851

    mrbisogno
    Member

    It is! :-)

    #564996

    mrbisogno
    Member

    One more blavatar question: My blavatar is now showing up both in tabs and browser window on http://blogbisogno.wordpress.com, but that url is forwarding to my .com, http://blog-bisogno.com. My blavatar does not show up there. Is this possible to correct?

    #565019

    redkeyhole
    Member

    I have the same problem – adding a new widget totally zaps what’s in the sidebar. So I went to the first link (posting by Panos). This says I the “default” widgets somehow are in the sidebar, but not really there??? So they need to be dragged into the sidebar – then they will stay there and I can add more as desired.

    PROBLEM: There’s no way I can see to identify which (“phantom”?) widgets are the default ones in (but not really in) the sidebar.

    This all seems kinda screwy. So for the moment, I still cannot add new widgets to the sidebar (theme is Jentri)…

    Thanks for any help…

The topic ‘Widget adding wipes out sidebar’ is closed to new replies.