Widgets and Scrolling Messed Up

  • Author
    Posts
  • #1023121

    benjammin1
    Member

    I am using the theme Coco for my blog. Today, I woke up to my front page gone haywire. 2 Problems:

    1) Prior to the first post, September’s posts are all moved way down in the page, and August posts are up near the top.

    2) If you scroll halfway down, you can see my widgets are repeated, and they are all messed up. You can also see my september posts, which are supposed to be near the top, located in the middle. The background is also messed up, leaving me to think the problem has something to do with the scrolling code.

    BTW, No custom css.

    I don’t know if this is the right forum to post this:) Oh well, the mod can move it to the right forum if he wants too. Thanks

    The blog I need help with is awesomewallpapersblog.com.

    #1023262

    timethief
    Member

    I am using Firefox 15.0.1 and I don’t see any repeated widgets in your sidebar. Please try clearing your browser cache and cookies http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    If required you can update the browser to the latest stable version here http://browsehappy.com/

    #1023264

    timethief
    Member

    September’s posts are all moved way down in the page, and August posts are up near the top.

    I don’t see that either.

    #1023267

    benjammin1
    Member

    I’m using Firefox 15.1 also. Tested in Opera too. Remember to scroll down halfway or more.

    Screenshot: Screenshot

    #1023292

    justpi
    Member

    I’m not seeing any of this either, in any of the browsers I’m using. But a likely culprit are the images in the text widgets, in particular the email one. (And that’s because you made the mistake of inserting them in a post first then copypasted their code in the widgets, instead of properly taking the width of the sidebar into account). The code of the email image says insert it at 126px wide, but the original uploaded image is 256px (which is a lot wider than your sidebar); some browser versions don’t understand the regular coding for displayed width: they may display the image in its original size or distorted and/or break the theme. Try editing the widget and replace this:
    <img class="alignnone size-full wp-image-1996" title="Email" src="http://awesomewallpapers.files.wordpress.com/2009/08/email256.png" alt="email256" width="126" height="126" />
    with this:
    <img style="width:126px;" title="Email" src="http://awesomewallpapers.files.wordpress.com/2009/08/email256.png" alt="email" />
    If that doesn’t change things, you’ll have to use an image editing application or an online tool to downsize the image to 126px, upload that version to your blog via Media > Add New, and use the new File URL you’ll get.

    #1023295

    I see the page anomalies. It is right after the June 5 post that the duplicate widgets show up and then after they do, the posts start again.

    #1023317

    benjammin1
    Member

    @justpl Thanks for the tip, will try it out.

    #1023318

    benjammin1
    Member

    @justpl Update: still didn’t work.

    #1023319

    benjammin1
    Member

    Update!! It was my fault. Somehow I completely copied part of my front page and somehow pasted it into a post.

    The mod can delete or close this thread now. Sorry for bothering everyone.

    #1023325

    debeckett
    Member

    Hi there, thanks for letting us know you’ve got it worked out ;-) .

The topic ‘Widgets and Scrolling Messed Up’ is closed to new replies.