Widgets not showing up

  • Author
    Posts
  • #1204075

    sumacny
    Member

    I’m a real newbie–tried to add Pages Widget to my pages but they don’t show up (nor do any of the other widgets I tested.) What am I doing wrong? Thanks.

    The blog I need help with is pontevino.wordpress.com.

    #1204219

    timethief
    Member

    Until you publish the widget has nothing to display
    Are you using this guide? http://en.support.wordpress.com/widgets/pages-widget/

    All widget guides are found here > http://en.support.wordpress.com/category/widgets-sidebars/

    #1204221

    timethief
    Member

    add Pages Widget to my pages

    Pages widgets are not added to Pages. They are displayed in areas for widget display which is either in sidebars or footer areas of the blog.

    #1204227

    sumacny
    Member

    I have published and updated. I’m using twenty eleven with a left hand sidebar. The dashboard says I have four pages with two widgets (I only have one, as far as I know–the pages widget). The only thing that shows up on the left hand side of the pages is an edit button. Clearly, I’m missing something! I have read the documentation, and done the dragging and dropping as suggested.

    #1204229

    timethief
    Member

    There is no sidebar on single posts (Twenty Eleven). Read this please > Twenty Eleven

    Also note that you have a private blog and we Volunteers cannot view it so helping you amounts to working in the dark. Your choices are to make the blog public (if you want support from Volunteers) or to type modllok into the sidebar and wait for Staff help.

    #1204230

    timethief
    Member

    edit: modllok = modlook sorry :(

    #1204247

    sumacny
    Member

    Thanks.That’s an obscure feature, since the theme lets you specify a sidebar and says nothing about single posts. I’ll poke around and find something else.

    I made the blog private because I’m really just beginning to learn the system, and I’d just as soon mess things up in private. Once I know what I’m doing, I’ll go public.

    Thanks for your help. What a great response time!

    #1204352

    justpi
    Member

    a) 2011 has three layouts: sidebar left, sidebar right, no sidebar. So first you must make sure you’re using one of the sidebar layouts (Appearance > Theme Options).
    b) Even when you use a sidebar layout, the default for static pages is no sidebar. If you want the sidebar to show when viewing a static page, you edit the page and select the sidebar template instead of the default template.

    #1204396

    sumacny
    Member

    Thanks! I had selected the left sidebar, and assumed that that was now my default template. But selecting the sidebar template solved the problem. I appreciate all the help.

The topic ‘Widgets not showing up’ is closed to new replies.