Need help? Check out our Support site, then

With infinite scroll, not all "Official" sharing buttons work

  1. If you enable infinite scroll, enable sharing buttons on "Front Page, Archive Pages, and Search Results ", and set the button style to "Official buttons", not all of them work. For instance, I enabled Twitter, Pinterest, Plusone, and LinkedIn, and for posts that were loaded via ajax, the latter two buttons don't show up.

    The blog I need help with is

  2. Do you also encounter this issue in a different browser? for example Firefox or Safari?

    Sorry for the inconvenience.

  3. Thanks @kardotim. Yes, it appears to happen in every browser. It looks like Jetpack has some code for Pinterest to load it on the custom JS event "post-load"; I think this functionality was overlooked for some of these buttons.

  4. Could you send us a screenshot of the page where you're seeing this?

  5. Sure thing, here you go:

    I highlighted and annotated the relevant areas of focus.

    This behavior is demonstrated at, but I've also replicated it in a vanilla install (bleeding edge nightlies) using twenty ten, twenty eleven, and twenty twelve, with no other plugins enabled, to rule out variables. As I mentioned, I noticed that for Pinterest there is a post-load event,

    jQuery(document).on('ready post-load',...

    but there isn't one for other services. Hopefully that points you in the right direction!

  6. Hi there,

    Thanks for the screenshot - it's very helpful! I've alerted our internal team. We'll let you know what we uncover.


  7. Hi again,

    The team has let me know that this was fixed in what is now the latest version. Could you update your Jetpack and see if the problem persists?


  8. Hi zandyring,
    It is still not working for me on WordPress 3.5 and Jetpack 2.0.4, nor the nightlies of both (3.6a and 2.1a respectively). Sorry :-(


  9. Hi Matt,

    I'm very sorry - I didn't get alerted to this reply of yours. I apologize.

    So in the interim, Jetpack 2.1 was released - with this Jetpack version enabled, is your problem solved? If not, I'd be happy to keep working with you on it!

  10. Hi zandyring,
    It looks like 2.1 did resolve this issue, thanks!


  11. Terrific!

    Happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.