WordPress 2.5 – Clicking the HTML tab while editing a post breaks things

  • Author
    Posts
  • #209969

    vissago
    Member

    When editing a post in wordpress 2.5, if one were to click the HTML tab in the editor – the edit box dissapears (css collapse?) and you cannot get it back unless you refresh the page.

    #210499

    Try clearing your browser cache. It could be that it is trying to use an old file in your cache.

    #210501

    infolution
    Member

    thesacred, that does not work, it is not OUR problem it is whomever created 2.5..

    #210502

    vissago
    Member

    its not a browser cache issue, I have caching turned completely off in firefox in the about:config section.

    #210506

    Infolution, you’re on your own then.

    #210531

    @vissago

    I did some rooting around on the .org forum, and I have one more suggestion. Open the editor, switch to the HTML tab and force reload the page. That has worked for some using 2.5 on self-hosted blogs.

    #210533

    The reason I suggest this, is that there may be a proxie server somewhere between you and wordpress (not necessarily one you know about) and doing a force reload on that page may cause get the proxie server to reload the files that are used for the html tab.

    It’s worth a try.

    #210539

    This worked for me –
    go to wp-content/uploads/js_cache
    delete tinymce references here.

    Delete wp-admin
    re-upload.

    #210541

    We do not have access to those files, nor can we upload or change the underlying files since we all use the same underlying files on this multi-user version of WordPress. It works differently than the single-user software downloaded and used from wordpress.org.

    #210544

    tamashii
    Member

    So what is your suggestion for those not on the self-hosted version of WordPress? The simpler answer here is something is messed up and wasn’t tested fully before releasing it into the wild.

    I can’t even use the toolbar to add a link – I MUST go into the HTML viewer and hand add a link.

    #210549

    I’m having absolutely none of the problems others are and I know at least 12 others that are not either. I’m reluctant to say that since some may want to stone me to death. In my experience, 2.5 is quite solid and stable, but there are a lot of things on the internet between you and wordpress.

    While the visual editor is open, go to the view menu and force reload the page. One of the things that can cause this is if somewhere between you and wordpress there is a proxie server that caches files to reduce bandwidth use (and you would not know if there was or not), and if that is the case, then it could be that there is an old version of a file on that server that it is sending to you. Force reloading the page may cause the proxie server to go out and get new copies of the files

    #210551

    Also, what browser and version and operating system are you using?

    #210553

    dosadi420
    Member

    @thesacredpath

    i can’t seem to upload my videos into new posts – instead of having a playable vid when the post is published, I just have the tail-end of the vid’s url linking to the vid’s page.

    any ideas? thanks.

    #210562

    Hmmm, I’m not sure. Do you have an example up on your blog that I could look at?

    Are they youtube’s or do you have the space upgrade and uploading them to your blog space?

    #210568

    dosadi420
    Member

    you just helped me on another page.
    the vids work now.

    thank you

    #210570

    You’re very welcome, happy blogging.

    #210955

    vissago
    Member

    Forcing the reload works but it adds in paragraph tags and other tags.

    I can’t go into the file structure and delete anything at this point because 1) the blog went live (www.startupsd.net) and I’m no longer an administrator – they only gave me admin access while I was setting things up.

    I tried a number of other things – disabling ad block plus, changing browsers.. doesn’t seem to help

    @thesacredpath: I don’t think its a proxy issue because I actually run a secure proxy at my house, so I can turn that on and off at my leisure and it makes no difference. I’m also aware of the hosting facility at which the blog is hosted, and I’m certain there are no proxies between myself and the site.

    I have a feeling its css/code related on the wordpress side and I imagine there might be a patch or fix or something – so im expecting 2.6 soon
    heh

    #210956

    @vissago

    That is a self-hosted WordPress blog and not hosted here at wordpress.com. You need to inquire over at http://wordpress.org/support/ . This is the technical support forum for those using the wordpress.com free hosting service.

    #210964

    infolution
    Member

    HELP

The topic ‘WordPress 2.5 – Clicking the HTML tab while editing a post breaks things’ is closed to new replies.