WordPress malfunctioning. Need help.

  • Author
    Posts
  • #913414

    I was having the same problem – nothing worked in Dashboard in Firefox 12 (Mac). I updated to Firefox 13. Still nothing worked. I disabled all extensions and add-ons, and added them back one at a time.

    What I needed to do was disable AdBlock for wordpress.com, and then everything worked again. Before today, it worked with AdBlock enabled.

    Perhaps that will help others.

    #913417

    I am not familiar with Chrome’s Dev tools. Hopefully this is what you’re looking for:

    GET https://s0.wp.com/_static/??/wp-includes/js/jquery/jquery.js,/wp-content/mu-plugins/subscriptions/follow.js,/wp-admin/js/utils.js,/wp-admin/js/blog-switch.js,/wp-content/admin-plugins/post-ads/post-ads.js,/wp-content/mu-plugins/kissmetrics/kissmetrics.js,/wp-includes/js/spin.js,/wp-includes/js/jquery/jquery.spin.js,/wp-content/admin-plugins/after-the-deadline/atd.core.js,/wp-includes/js/quicktags.js,/wp-content/admin-plugins/after-the-deadline/atd-nonvis-editor-plugin.js,/wp-content/admin-plugins/after-the-deadline/jquery.atd.js?m=1339126651j post-new.php:34
    Uncaught ReferenceError: AtD is not defined admin-ajax.php:1
    Uncaught ReferenceError: jQuery is not defined s0.wp.com:75
    Uncaught ReferenceError: jQuery is not defined post-new.php:60
    Uncaught ReferenceError: jQuery is not defined s0.wp.com:334
    Uncaught ReferenceError: jQuery is not defined wpgroho.js:1
    Uncaught ReferenceError: jQuery is not defined post-new.php:1192
    Uncaught ReferenceError: jQuery is not defined post-new.php:1263
    Uncaught ReferenceError: AtD is not defined admin-ajax.php:1
    Uncaught ReferenceError: jQuery is not defined s0.wp.com:1
    Uncaught ReferenceError: jQuery is not defined post-new.php:1475
    Uncaught ReferenceError: jQuery is not defined post-new.php:1638
    Uncaught TypeError: Object #<Object> has no method ‘addToLang’ en.js:1
    Resource interpreted as Image but transferred with MIME type text/plain: “https://pixel.quantserve.com/pixel;r=1361530803;a=p-18-mFEk4J448M;labels=%2Clanguage.en%2Ctype.wpcom%2Cwp.loggedin%2Cwp.admin;fpan=0;fpa=P0-1807312315-1287959081785;ns=0;ce=1;je=1;sr=1680x1050x32;enc=n;dst=1;et=1339457115358;tzo=420;ref=http%3A%2F%2Ftheintrepidphotographer.wordpress.com%2F;url=https%3A%2F%2Ftheintrepidphotographer.wordpress.com%2Fwp-admin%2Fpost-new.php%3Fpost_type%3Dpost;ogl=”. quant.js:23
    Uncaught TypeError: Object #<Object> has no method ‘addToLang’ en.js:1
    Uncaught ReferenceError: getUserSetting is not defined editor_plugin.js:1

    #913419

    macmanx
    Staff

    Excellent, thanks for letting us know!

    Anyone else here using AdBlock?

    #913420

    macmanx
    Staff

    coffeezombiephotog, thanks for sending that in!

    #913421

    I’m using adblock and tried all of the above to no avail. Incredibly frustrated right now, guys.

    #913422

    I just disabled AdBlock too, and the editing tools are back in place.

    #913423

    macmanx
    Staff

    birthofanewwitch, are you familiar with Chrome’s Developer Tools or Firebug http://getfirebug.com/ ?

    If so, would you mind quoting any JavaScript errors that you see?

    #913424

    macmanx
    Staff

    coffeezombiephotog, thanks for confirming!

    #913425

    I’m on firefox 13.0. Futzing with adblock now…

    #913426

    Not familiar with Firebug. :(

    #913427

    eenobbs
    Member

    YES!!! The Adblock thing disarmed worked for me too!! Thanks sensuousinkspiller and everyone :-)

    #913428

    Okay, it works when Adblock is off. But uh, I kind of like Adblock on because I do several things at once – can you guys fix this bug so I can leave Adblock on?

    #913430

    Same problem, here. Blog posts do not show up on editor screen unless I highlight.

    I cleaned cache and cookies on chrome and firefox. I also rebooted browsers. Nothing works. I still have the same problem.

    ChristyFarmer.wordpress.com

    #913432

    macmanx
    Staff

    christyfarmer, I assuming you’re running AdBlock. If so, please try disabling it to see if that makes any difference.

    Everyone else, AdBlock should have a whitelist feature. If so, please add *.wordpress.com and *.wp.com to it.

    #913433

    No, I’m not running AdBlock on Google Chrome.

    #913434

    macmanx
    Staff

    To all AdBlock users, I did some digging and found that you can report that AdBlock is interfering with a website: https://adblockplus.org/en/getting_started

    Also, it looks like specific sites can be whitelisted right from the menu: https://adblockplus.org/en/faq_basics#disable

    christyfarmer, please try a different browser, like Firefox, and let us know how it goes.

    http://browsehappy.com/

    #913435

    northessexas
    Member

    Disabling AdBlock Plus in Firefox brought back the functions.

    This issue hasn’t happened before. Don’t really want to disable AdBlock so will try to work out how to whitelist.

    Thanks for help.

    #913438

    macmanx
    Staff

    You’re welcome!

    #913439

    The problem continues. I have used three different browsers now.
    ChristyFarmer.wordpress.com

    #913441

    Okay, on Firefox 13 you just have to go into adblock and click on “disable on this page only”, and it works just fine.

    However, I’d still really like you guys to fix this bug (if possible) and not just have to disable adblock whenever I need to edit something. :/

    Thanks in advance!

The topic ‘WordPress malfunctioning. Need help.’ is closed to new replies.