Need help? Check out our Support site, then


WordPress Reader page no longer has infinite scroll?

  1. I don't have time to check the WordPress Reader for new posts every day, but it used to work out great anyway. I would merely scroll down; the infinite scroll feature would kick in, and I could see older posts and catch up. Now the reader only seems to show a finite number of posts (right now it's seven). If I try to scroll down beyond this, nothing happens.

    If this is supposed to be showing me all the posts that have been published since I last checked in, it isn't working. I'm missing many posts.

  2. H there,

    In order to help you we need to know your specific computing environment details. Please work through what follows and report back.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:
    http://browsers.about.com/od/howtousemobilebrowser1/ss/safari-ipad-clear-cache.htm
    http://browsers.about.com/od/howtousemobilebrowser1/ss/How-To-Clear-Browsing-Data-In-Chrome-For-Ipad_6.htm

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) And what any error reports you receive state.

  3. I have three browsers installed on my laptop. I use Firefox most of the time, and Opera some of the time, and Internet Explorer almost never. When infinite scroll stopped working in Firefox and Opera, I thought WordPress had disabled the infinite scroll feature. After your feedback, I loaded the WordPress Reader in Internet Explorer, and discovered that infinite scroll was still working in IE. Returning to Firefox and Opera, I was able to isolate the source of my problem.

    In both Firefox and Opera, I had installed the Adblock Plus extension. With that extension, it is possible to subscribe to different lists of material to block. It turns out that a specific list called, "Easy Privacy," is now blocking certain WordPress-related material. This list must have incorporated new WordPress material recently because I've been using Adblock Plus and this list for some time, and it has only been recently that Reader stopped behaving normally in my browsers. I have re-enabled Adblock Plus (minus the Easy Privacy list), and now infinite scroll is working once again in the WordPress Reader.

    Thanks for your suggestions.

Topic Closed

This topic has been closed to new replies.

About this Topic