WordPress RSS feed not working.

  • Author
    Posts
  • #1470787

    kraftbj
    Staff

    Howdy,

    Sorry for the delay!

    First, I must apologize. I overlooked that you were using the archiveorg shortcode. So good news, I found the issue. Bad news is I could have caught it sooner :-/

    To make up for it, I’ve fixed all of your current posts so they work and gifted you a 10 GB space upgrade for the year.

    How to do it so it works moving forward:
    Two ways. One depends on WordPress.com’s space upgrade being active. With this option, you can continue using it until you run out of space or the upgrade expires. If it expires, everything already uploaded will stay, but nothing more can be uploaded.

    1. Prepare the MP3 audio file as normal.
    2. Start your WordPress.com post as normal.
    3. Instead of doing anything at archive.org, instead, click the Add Media link in the post editor.
    4. Upload the MP3 file in the pop-up that shows up.
    5. After it is uploaded, insert it into the post. It’ll appear in the editor like [audio http://example.files.wordpress.com/2013/10/file-name.mp3]
    6. Save your post. Done!

    Option 2 is along the same lines as you’re doing now, tweaked it work. I didn’t test this since I don’t have an account at archive.org, but happy to figure out any issues that may come up if this doesn’t work.

    1. When saving the audio file, use all lower case, no spaces and no special characters, except hyphens. e.g. pastor-hill-sermon.mp3 and NOT Pastor Hill Sermon Today!.mp3. (All of the current audio files have spaces, which is why I believe this didn’t work for me initially).
    2. Upload to archive.org as before.
    3. On the audio’s details page, e.g. https://archive.org/details/PastorJillSmithWhatItIsToBeThePeopleOfGod , right-click or option-click on the size of the file under VBR MP3. See here: https://cloudup.com/cpwOIaCeTil
    4. Click Copy Link
    5. In the WordPress.com editor, manually type [audio
    6. Paste the address so it appears like [audio https://archive.org/download/PastorJillSmithWhatItIsToBeThePeopleOfGod/PeopleofGod.mp3 ]
    7. Save post. Done!

    Please let me know if you have any questions. My apologies again for missing this the first go around.

    #1470788

    Eureka! Thank you :) I’ll explore all the options later today in the chance that I might catch you before you leave for the day. I checked the iTunes podcast subscriptions and there was a download waiting for me. Very exciting. There are two details to resolve before I can submit the podcast to iTunes. The two issues are name and title picture. The iTunes podcast test still shows the extra bit at the end of the title, and I’m not sure how to go about inserting the title cover without it becoming another download to every one. If we can fix these two things I should be able to submit the podcast to iTunes tomorrow. Thanks again, you’re a godsend :)
    Blessings
    Warwick.

    #1470789

    Hi Brandon. Trust you slept well with the weight of our issues solved :) I had a great day following your breakthrough and have the picture loaded for iTunes and pretty much set to go bar the tidy up of the labels. I tried to get the iTunes heading to read “Pukekohe Community Church”, with the sub title in small font of “Connecting People with Kingdom Life & Purpose in Christ”. (removing the “- Shared Messages” ) On the SmartCast page of Feedburner, the sub title details are already loaded, along with “We are motivated by the mission of sharing the good news of Jesus Christ in Pukekohe, the Franklin District, New Zealand and beyond.” in the podcast summary option. Its not important to have the summary option if there isn’t enough room to display everything so if its an issue, then I’ll leave it out. The only other thing that I’ve noticed, is when you view the podcasts on either a smart phone or laptop, and select the area that gives you a summary about that particular podcast, it displays a lot of superfluous information that I would prefer not to be displayed. Its worse when the episode summary is brief, as in “What it is to be “The People of God”. All the information regarding “Filed Under” and “Tagged” etc, is either partially or completely displayed, depending on space. Is there a way to prevent that? (In the above case, even the coding of the audio is displayed when viewed with in iTunes) These are the last two points to resolve and then hopefully I can submit it to iTunes tomorrow :)

    #1470791

    kraftbj
    Staff

    Regarding the extra information:

    We can do better. The “Continued Reading” line will remain, but we can handle the rest. When writing the post in WordPress, there is an extra box for “Excerpt”. If you include the description there (as well as the main editor), Feedburner will use the Excerpt for iTunes, instead of however much of the main post content will fit.

    If you don’t seen Excerpt, try ensuring it is enabled via Screen Options.

    For the shorter title, have you tried editing the feed in Feedburner? Go to http://feeds.feedburner.com and click on the feed name. Then click on Edit Feed Details. That *should* be the place you’ll need to change it, but I could be wrong.

    How does that work for you?

    Cheers!

    #1470792

    Not working on either account at this stage. I had already tried to sort the name out in Feedburner and it is displaying correctly on the edit feed details – Feed Title, just not in the title when you click on the RSS link, or in iTunes. When I tried to use the excerpt button, I couldn’t find it and it appears its not an option in the theme that I am using. (Reddle) The support section showed me how to use the “more” tab and I thought it said that it would work the same way but after inserting it on each post, there is no change, although for some reason, the post “What it is to be the people of God” now displays perfectly in iTunes, with or without the “more tab ???

    #1470793

    kraftbj
    Staff

    Excerpt should be an option—I tested it out on “The People of God”, with the excerpt. Let me jump in and see if I can force it onto your screen.

    #1470794

    kraftbj
    Staff

    It wasn’t selected via the Screen Options field. You should see it now under the main blog content (and under the “Related Content” field).

    I’m not sure about the title. It seems to be an issue with Feedburner that I can’t duplicate on my test account.

    #1470795

    Talk about primed and ready to go! That was quick, and correct :) I thought maybe my eye sight was going as its not listed under screen options if you are on the “posts” or “all posts” pages, until you actually select the post, and then look under screen options. Sanity restored ;)
    1 down and 1 to go…. When you say that you can’t duplicate the title issues on your test account, do you mean you are seeing something different, or just can’t get to the same screens?

    #1470796

    kraftbj
    Staff

    When I change the feed title in details, it changes it elsewhere.

    Googling around, I found an alternative way. Within Feedburner, click on the Optimize tab, then the Title/Description Burner option.

    Let’s hope that gets everything straightened out for us!

    #1470797

    I think we are done :) I was surprised that when you change the feed details it changed elsewhere, as that doesn’t happen when I do the same. I did try the Title/Description Burner though and had a 50:50 success, but got the most important 50%. The name has changed successfully but the description seems to have disappeared into the great black void. It may be displaying somewhere, but exactly where, I do not know. No matter, end result is we are ready to submit the podcast. I can’t thank you enough for a job well done. Your persistence and help are very much appreciated. Have a greater weekend in a hopefully sunny Austin :) God Bless, Warwick.

    #1470798

    The above questions and responses will make for an excellent how to manual for future podcast setups.

    #1470799

    kraftbj
    Staff

    You too. After the weekend, I’ll review the Podcast support page and see where we can improve it based on our work together.

    Very glad you’re ready to submit! Peace!

    #1470800

    Hi Brandon, Just been doing a tidy up of the podcast after seeing it successfully added to the iTunes store and have a question for you please. The duration of each podcast is not showing on iTunes. I tried the iTunes forum and the issue seems to be that the iTunes tag ‘itunes:duration’ , is not included in feedburner. I do not know how to fix this but have found a closed forum topic on exactly the same issue, and it even has your input, but the topic was closed without an answer.
    ( https://en.forums.wordpress.com/topic/no-podcast-time-length-being-listed-on-itunes-store?replies=4 ) – Can you let me know if you solved it please, and if so, how do I fix it. Thanks, Warwick.

    #1470801

    kraftbj
    Staff

    Hi again!

    Unfortunately, my research has indicated this is a limitation of Feedburner. There are a lot of “special” fields needed for iTunes which isn’t part of the typical RSS feed. While Feedburner adds most of them, that one is not included.

    :-(

    Wish I had a better response for you! Hope all is going well.

    #1470802

    Thanks for your efforts :) All good down here. The duration tag would have been nice, but oh well. Lots of other refinements for me to work on ;)

The topic ‘WordPress RSS feed not working.’ is closed to new replies.