WordPress secure content message….

  • Author
    Posts
  • #1297966

    gwgreene
    Member

    On every page I display in WordPress; even the support page, I get the message “Only secure content is displayed. What’s the risk?”. It’s very annoying and makes WordPress basically un-useable; can I stop it?

    The blog I need help with is gwgreene.wordpress.com.

    #1298092

    Are you using internet explorer? Are you visiting the https version of the site? Try following the steps here: http://en.support.wordpress.com/https/#frequently-asked-questions

    #1298197

    gwgreene
    Member

    I’ve enabled HTTPS and changed the internet options as suggested but still get the “Only secure content is displayed….” message on every page within WordPress. I’ve also added https://wordpress.com to my trusted sites (it wouldn’t accept *.wordpress.com). Help…

    #1298198

    timethief
    Member

    Does what Staff (macmanx) says here help?

    It’s not necessary to browse via HTTPS on the front end.

    If you’re seeing the warning in your Dashboard too, you probably have a corrupt browser extensions trying to inject insecure content, like ads. https://en.forums.wordpress.com/topic/only-secure-content-is-displayed-in-admin-pages?replies=9#post-1231673

    It’s possible for ads to appear in your browser that were not placed there by WordPress.com. These ads are sometimes caused by malware or a virus, but more often it is due to a browser extension or toolbar that you may have installed in your browser. WordPress.com does not use text enhance or text link ads or pop-up ads or header ads or sidebar ads or links in comments. If you are seeing those then these sites have further explanation and suggestions for eliminating the ads: http://www.littletechiethings.com/2012/06/how-to-remove-ads-not-by-this-site.html http://blog.wikimedia.org/2012/05/14/ads-on-wikipedia-your-computer-infected-malware/

    #1298204

    gwgreene
    Member

    Not really, if browser extensions means “browser add-ons” in Internet Explorer, I have the following enabled: Adobe Shockwave Flash Object, Google Toolbar, Google Toolbar Helper, XML DOM Document, Spybot Search & Destroy Configuration and Spybot SD IE Protection.
    I get the “”Only secure content is displayed. What’s the risk?” message on all WordPress pages; very frustrating.

    #1298206

    gwgreene
    Member

    PS: i don’t get any Ads popping up, just the message “”Only secure content is displayed. What’s the risk?” so I don’t get the connection. tks

    #1298277

    kathrynwp
    Staff

    Are you viewing the front end (public side) of WordPress sites with http:// in the browser’s address bar, or https:// ?

    The front end is meant to be visited with http:// only.

    #1298289

    gwgreene
    Member

    I’m not sure what you mean by viewing the front end? I’m just trying to edit WordPress site; how can I choose between http & https?
    When editing the page, the url is displayed as https://gwgreene……admin/post.php?post=35&action=edit; is this correct or should it be http?
    I’ve disabled just about all the add-ons except the Microsoft ones, shockwave & Adobe PDF Reader and now I only get the message when I ‘Preview’ the page I’m editing instead of every page in WordPress.
    Thanks for your input.

    #1298297

    kathrynwp
    Staff

    Previewing a page should give you a URL like:

    http://gwgreene.wordpress.com/?p=596&preview=true

    Note the first part – this should not be a secure URL, it should only have http – not https.

    Could you please check this in your browser? Does it show http or https?

    I’ve also added https://wordpress.com to my trusted sites (it wouldn’t accept *.wordpress.com).

    Could you please try adding http://gwgreene.wordpress.com and https://gwgreene.wordpress.com there as well?

    Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

    Let me know how it goes.

    #1298300

    gwgreene
    Member

    I’ve done what you suggested but still get the “Only secure data is displayed” message when I preview the page. Here’s the url for the preview which looks good: http://gwgreene.wordpress.com/home-2/?preview=true&preview_id=35&preview_nonce=5d18d9ef95
    I’ve added the url’s you suggested and unchecked the “Require server notification (https)” box.
    Thanks again for your help with this frustrating issue.

    #1298301

    kathrynwp
    Staff

    Could you please try enabling “mixed content” following the directions here:

    http://www.petenetlive.com/KB/Article/0000502.htm

    Let me know how it goes.

    #1298302

    gwgreene
    Member

    Thanks so much, it worked! I’m not sure which of the things actually had to be done to fix the problem but it’s ok now.
    Another thing is that when I select ‘my blogs’ I get the message “Displaying content with security certificate errors”. Any idea why? Thanks again, gwgreene

    #1298303

    kathrynwp
    Staff

    I’m very glad that worked!

    Another thing is that when I select ‘my blogs’ I get the message “Displaying content with security certificate errors”. Any idea why?

    There are some ideas here:

    http://social.technet.microsoft.com/Forums/en-US/ieitprocurrentver/thread/3305deb3-2276-4faf-a647-2461799da9d9/

    #1298318

    gwgreene
    Member

    Thanks kathrynwp for all your help. Now, how can I close this forum? I have another issue now; should I start another topic? tks, gwgreene

    #1298320

    1tess
    Moderator Emeritus

    I’ll mark this as resolved for you.

The topic ‘WordPress secure content message….’ is closed to new replies.