WordPress will not add media to my page

  • Author
    Posts
  • #2404225

    I’m attempting to add my updated resume to a page. When I select it from it the media library and hit ‘insert into post’. It does nothing. It also will not permanently delete my old resume. I’ve tried both IE and Chrome platforms.

    This is highly frustrating. If I cannot get this to work I will be forced to find another site to host portfolio..and just when i was going to PAY for an upgrade.

    The blog I need help with is whattheconcept.wordpress.com.

    #2404320

    justjennifer
    Moderator

    If you just want your site visitors to be able to download the PDF file, here’s how you insert the link: https://en.support.wordpress.com/uploading-documents/

    If you want to actually embed the PDF file in your page, here’s how you do that: https://en.support.wordpress.com/scribd/

    If you need more help, please post back here.

    #2404326

    justjennifer
    Moderator

    It also will not permanently delete my old resume

    As far as deleting your old resume, when did you delete it from the Media Library? The background cache can take about 3 days to empty.

    Even if you uploaded the file with the same name, WordPress.com will automatically append a number 1 to the file name. If you are seeing the old file, please try refreshing the page and/or logging out of WordPress.com, deleting your browser cache and cookies (which will log you out of every site you are logged in on) and then looking again at the file.

    Again, if you need more help with that or have questions, please post back here.

    #2404331

    I know HOW to do it…it won’t WORK. That’s the issue. I cannot insert or add ANY new media to a page. I can upload it into the libray just fine, but it will not add to the page.

    #2404336

    justjennifer
    Moderator

    So the instructions for inserting a link to the PDF fail when you are in the Media Manager and choose “Media File” in the Attachment Display Settings and click “Insert into Post”?

    Are you inserting the link from the WP Admin Classic Dashboard or the New Blue Dashboard?

    Which version of Chrome and IE are you using? http://whatbrowser.org/

    #2404344

    justjennifer
    Moderator

    Just to test this for myself, I’ve created a test post with both a download link to a PDF file uploaded to my test site’s Media Library as well as a Scribd embed following the instructions in the two Support documents I linked to above. Both methods worked for me in the WP Admin Classic Dashboard Post Editor using Chrome 43 (latest).

    You can see it temporarily here.

    I do see on your Resume page links to two different PDF files:
    angie-longacre-resume_graphic-design.pdf
    angie-longacre-resume-_writer_2015-update1.pdf

    If either one of those files is the one you permanently deleted from your Media Library, it is indeed still accessible via the download link on that page.

    You can edit that page to remove the unneeded link and then return to this thread and add a MODLOOK tag for Staff assistance in permanently removing the deleted file.

    #2404353

    Interesting. I was attempting to load form the new blue Dashboard – I don’t know how to get back to the old one – like that much better. I’m using the latest versions of both browsers.

    The new file I was attempting to load on that particular page is the “2015 update” file. When I look at the preview it didn’t show. But now I see long link (https://whattheconcept.files.wordpress.com/2013/11/angie-longacre-resume-_writer_2015-update1.pdf)
    And I don’t want this. I want the link just as you have listed it.
    Can you tell me what you see now? I’ve updated that resume link again to test and attempted to add create a gallery, but nothing is inserting for me.

    As for the file wanted to delete, I deleted the link, but it won’t delete form the media library.

    #2404359

    justjennifer
    Moderator

    You've caught me just as I've gone offline for the night. I'm posting this via my phone. If you'd be willing to wait I'd be happy to help you tomorrow when I'm back online. Otherwise perhaps one of the other forum volunteers would be able to assist in the meantime.

    #2404447

    justjennifer
    Moderator

    Getting back to writing in the Classic Dashboard: If you prefer to create/edit your posts/pages in the Classic Dashboard, do not use the “pencil icon” or New Post/Page link from the Admin bar or the Edit link that appears on the front facing side of your site. You can access your Classic Dashboard here: https://whattheconcept.wordpress.com/wp-admin/ and then navigate to either edit or create a new post or page from there. I’d bookmark that link.

    There was a long forum thread after WPcom removed the link from the New Dash to the Classic Dash where some other suggestions were made including adding a Greasemonkey script to your browser that forces these links back to the Classic Dashboard. If relevant let me know.

    #2404448

    justjennifer
    Moderator

    Back to your questions:
    Right now, all I see on your Resume page is a single long link to
    angie-longacre-resume-_writer1.pdf

    I’m not certain I understand what you mean by

    And I don’t want this. I want the link just as you have listed it

    .

    How so? With a shorter/different name? If so, after uploading you can edit the Title of your file in the Media Library. Hover your cursor over the file there and select “Edit” from the choices that appear. Make your change and click Update to save the changes.

    Note: This will change the link Title (what is inserted in the post/page), but not the name of the file itself. It also does not change the title of links already inserted. To do that, you’d need to delete the existing link and reinsert it after changing the link title in the Media Library.

    As for the file wanted to delete, I deleted the link, but it won’t delete form the media library.

    Deleting a link to a file in a post or page doesn’t delete the file itself. You have to do that directly in the Media Library. Again hover your cursor over the file until you see “Delete Permanently” appear. Once you click that, you won’t be able to recover the file as there is no “Trash” folder for Media files.

    Please note that all the testing I have done so far was in the Classic Dashboard. I will test with the New Dash as soon as I am able.

    #2404449

    justjennifer
    Moderator

    I’ve updated that resume link again to test and attempted to add create a gallery, but nothing is inserting for me

    Instructions for creating and inserting a Gallery can be found here: https://en.support.wordpress.com/images/gallery/ The actions should be the same for both the Classic Dashboard and the New Dash.

    Since you said both your browsers are giving you trouble, it may be worthwhile working your way through the browser troubleshooting Support doc. There could be a computer/browser setting that needs tweaking. https://en.support.wordpress.com/browser-issues/

    If after working through that Support doc nothing is working, please let us know, especially what happens after you click the “Add Media” button from within the post/page.

    Does the Media Manager load for you? If so, do you see the “Create Gallery” link in the left side of the Media Manager window?

    #2404525

    justjennifer
    Moderator

    I see that you’ve resolved this issue and that you are able to insert media again.

    If you need any further help, please let us know by opening a new thread.

    #2404526

    Thank you. Yeah, I didn’t really “resolve” anything…it just began magically working again. Technology drives me insane.

    #2404530

    justjennifer
    Moderator

    Well that’s good news! If nothing else, I hope you are now able to get back to writing in the Classic Dashboard.

    Like I said, bookmark that link because it seems like getting there has become an egg hunt.

    #2404544

    Hey there,

    Just when I thought things were going ok. Can you give me any tips – to tell me if there is a way to lay out my samples more evenly. The first three are PDFS and JPEG. I think it looks awkward.

    https://whattheconcept.wordpress.com/writingsblog/?preview=true&preview_id=219&preview_nonce=81d7696f7d
    THANKS!

    #2404556

    justjennifer
    Moderator

    I’d be happy to do so, but forum volunteers cannot see previews. Only published posts/pages.

    Regardless, you might want to try using an HTML table to lay out your thumbnails. This is the best guide I know. https://wpbtips.wordpress.com/2013/04/09/table-coding-for-wordpress-com-users/

    #2404571

    daluxedotcom
    Member

    Hi…i am here for the same reason as the person who started this post.

    I’ve been using WordPress for 7 years, same blog. Today I made a post and uploaded two photos to the media library.

    Selected two photos and clicked “Add to post” and…

    Nothing. CLICK CLICK CLICK NOTHING NOTHING NOTHING.

    Grrrrrrrrrr………..

    #2404578

    justjennifer
    Moderator

    What is the URL of your site hosted by WordPress.com that you are having trouble with? The site linked to your username is not hosted here.

    #2404587

    hmalapanis
    Member

    I’m having EXACTLY the same two problems as the original poster: I can’t load any new images, and when I delete images from my media library, they reappear as soon as I view the media library again after navigating away. It’s been over a week that I’ve been having this problem. In the intervening time, I’ve restarted my photo program (Apple’s Photos), restarted my internet browser (Safari), and restarted my computer, all more times than I can count. I’ve also updated Photos since then. My allotted photo space on Word Press is only half full, so I’m pretty sure it’s not that.

    #2404588

    To the others that posted about having the same issue. I honestly did not find a solution…I waited it out. The next it was fine, as if by magic. Very frustrating, indeed.

The topic ‘WordPress will not add media to my page’ is closed to new replies.