Need help? Check out our Support site, then

Wordpress won't let me login to post comments to a blog

  1. I'm completely perplexed by this one.

    I have a WordPress account. I am logged in. I visit a new blog that I'm now following and go to make a comment. My WordPress ID appears below the reply text area. I enter my content and then click "Post Comment", but I'm given a login dialog instead. The warning says "You're trying to publish a comment as [name] You need to log in to that account before you can proceed." And to the right of this is also "You are being asked to login because [name] is used by an account you are not logged into now." But, I am logged in. So I supply my proper login credentials in this dialog, but they are NOT ACCEPTED. Exact same ones that I use when logging into my wordpress dashboard. In fact, I see my WordPress management bar at the top of the browser, despite this conflict of validation.

    OK, so I thought it was a cookie problem. I cleared my WordPress cookies, set the browser (Chrome) to accept everything, but the problem persists. I then went to Internet Explorer and tried again. SAME PROBLEM. I am not an idiot. I know how to log in. Am I caught in the Twilight Zone or something? I searched Google but found no recent comments about this kind of issue. I browsed the WordPress support forum and haven't found a post about it.

    If anybody has an idea, I'd love to hear it. The blog I'm trying to post to is "".

  2. You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at If your question is about a self-hosted WordPress blog then you'll find help at the forums.

    If you don't understand the difference between and, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

  3. ^ I was presented a dropdownlist where I was supposed to select either a specific WordPress blog, or if I was having a problem with in general. Well, the issue is with commenting on a blog, but there was no facility for entering the URL or name of that blog, just "--". So I couldn't specify the blog. Why?

  4. Well...

    Apparently it was some kind of "temporary glitch". Several hours later, I tried again and now my post as been accepted (awaiting moderation).

    Why did this issue happen? Is there some kind of delay between following a blog and being able to comment on it?

Topic Closed

This topic has been closed to new replies.

About this Topic