WordPress.com App for Windows Crashes

  • Author
    Posts
  • #2515533

    jalexartis
    Member

    First, I really, really like the new stand-alone [non-browser] application for WordPress.com; but…

    Regrettably, I sometimes experience black screen crashes on 2 events:

    1) Uploading media–selecting add media to select the file to upload may give an unrecoverable black screen. Closing the app and reopening does not recover–black screen remains. I use the Task Manager to kill the app. Only then can I use the program again. My work around is to use my browser site URL to add media and then go back to the WordPress.com App to continue editing to publish my article.

    2) Previewing articles can also cause a black screen crash. I must use the Task Manager to recover.

    These are major problems for me, yet do not alter my affection for the app. Bugs happen. I trust these will be squash soon.

    Thanks!

    Jim Artis [jalexartis]

    I use the app on a Windows 10 Pro desktop. I use the Edge Browser.

    The blog I need help with is cyclingexperiences.com.

    #2515592

    jalexartis
    Member

    I blog with the Twenty Sixteen Theme. Luv it!!! Thanks!

    #2515602

    kokkieh
    Staff

    Hi there,

    Thanks for reporting this. Can you please confirm which version of the app you’re using? You can see that under Help ->About in the app menu.

    #2515606

    jalexartis
    Member

    Sure.

    The release is 1.1.2.

    Thanks for the acknowledgement.

    Jim

    #2515645

    kokkieh
    Staff

    Hi, Jim

    I don’t have Windows 10, but I do have 7 and am not able to reproduce the error there. I’m asking a colleague who has 10 to help with testing this, and will get back to you once I have more information.

    To rule out a possible cause, can you please check if the crashes happen when you use a different connection, for example when connecting via your phone?

    Can you also provide more information about your system, specifically your processor type and speed, as well as the amount of RAM in your machine?

    In your original post you say this happens “sometimes”, so not each time you perform those actions? Can you think of anything you differently the times it does happen vs the times it doesn’t? If we understand exactly what you do it makes it more likely that we can reproduce the bug, and then we’d know better how to fix it.

    #2515649

    jalexartis
    Member

    Good Morning Kokkieh,

    I understand duplicating a problem to resolve. I have an HP Notebook. It is a TouchScreen PC. Before the kept Insights Posting Activity Grid from displaying in one of my browsers on my Windows 8.1 desktop. That is not a problem with the Edge Browser.

    I connect using an Ethernet cable plugged into my cable modem. I will change to WIFI and test using my phone as a hotspot. I do not suspect connective as a problem source. The problem happen 95% of the time. In terms of uploading pictures, I have avoided because on persistent crashes. My workflow is the same. I’ll see if I can pinpoint differences when the black screen crash do not happen. To this point I think maybe random–more difficult to fix.

    System Information:

    OS Name Microsoft Windows 10 Pro
    Version 10.0.10586 Build 10586
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name HP-ENVY
    System Manufacturer Hewlett-Packard
    System Model HP ENVY TS 15 Notebook PC
    System Type x64-based PC
    System SKU E0K02UA#ABA
    Processor Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s)
    BIOS Version/Date Insyde F.53, 3/5/2014
    SMBIOS Version 2.7
    Embedded Controller Version 147.73
    BIOS Mode UEFI
    BaseBoard Manufacturer Hewlett-Packard
    BaseBoard Model Not Available
    BaseBoard Name Base Board
    Platform Role Mobile
    Secure Boot State On
    PCR7 Configuration Binding Not Possible
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume2
    Locale United States
    Hardware Abstraction Layer Version = “10.0.10586.0”
    User Name HP-ENVY\jalex
    Time Zone Eastern Standard Time
    Installed Physical Memory (RAM) 8.00 GB
    Total Physical Memory 7.89 GB
    Available Physical Memory 3.33 GB
    Total Virtual Memory 16.4 GB
    Available Virtual Memory 10.5 GB
    Page File Space 8.50 GB
    Page File C:\pagefile.sys
    Hyper-V – VM Monitor Mode Extensions Yes
    Hyper-V – Second Level Address Translation Extensions Yes
    Hyper-V – Virtualization Enabled in Firmware No
    Hyper-V – Data Execution Protection Yes

    I hope this helps.

    Jim Artis

    #2515655

    kokkieh
    Staff

    Thanks for this information.

    The developer who’s helping me look into this has asked for a step-by-step breakdown of how you add media. Do you click the Media icon in the toolbar and then Add New, or are you trying a different method, like drag-and-drop? If the latter, into the Select Media screen, or directly into the editor?

    Thanks.

    #2515657

    jalexartis
    Member

    No drag and drop.

    1) I click the Add Media icon in the upper left of the toolbar
    2) I select Add New
    3) I select the file I want to add from Explorer
    4) I select insert

    The crash is random. It has occurred after steps 1 & 2.

    I sometimes get a black screen crash after selecting Preview.

    I make the selections using my mouse.

    I hope this helps…

    Jim

    #2515658

    jalexartis
    Member

    I uninstalled the app, downloaded again, and installed from the new download.

    The new install also gives me random black screen crashes.

    Of 10 efforts to add media to a test post, 7 worked [no crash] and 3 did not work–crashed.

    My last crash happen just after selecting the file. I will now focus on that file.

    jaa

    #2515659

    jalexartis
    Member

    It is not the image. No crash this time.

    FYI, I have very fast Internet Speed. I upload at 20+ mbps.

    jaa

    #2515697

    kokkieh
    Staff

    Thank you again for the detailed information. I have passed it along to our developers, and I’ve also mentioned your thread about the stats insights issue in case the touch screen might be an issue here.

    Meanwhile, can you please check whether your computer’s drivers for the touch screen is up to date? Especially if you had upgraded from 8.1 to 10 the drivers might be outdated, but even if you did a clean Win 10 installation this might still be an issue. You should be able to get the latest drivers from your computer manufacturer’s website, or you can try Windows’s instructions here:
    http://windows.microsoft.com/en-us/windows/update-drivers-recommended-links#update-drivers-recommended-links=windows-7

    #2515701

    jalexartis
    Member

    SOLUTION: Disable Touch-Screen Driver [work around anyway]

    Result: Both Google Chrome & The WordPress.Com Windows App display the Posting Activity Grid.

    Driver: 10.0.10586.0 dated 06/21/2006. A search for the latest driver finds the installed driver is the most current.

    Sending me to find the latest driver caused me the disable and then confirm the switching the driver on & off is indeed the single function that allows the desired display to be seen.

    I will now test to see if The WordPress.Com Windows App crashes when trying to upload pictures and/or previewing a post.

    It seems we are on a good road for this issue. We know for sure it is the driver [software] versus hardware of OS.

    Thanks for the idea. I’ll get back with you soon…

    Jim

    #2515702

    jalexartis
    Member

    Well, disabling the Touch-Screen Driver is not a panacea on my system.

    I have had multiple [more than 5] black-screen crashes as I prepared a post for publishing, e.g. selecting …More Options to enter an excerpt; selecting Categories & Tags, etc.

    I’ll let you know on picture upload as soon I have some to upload.

    Thanks!

    #2515712

    jalexartis
    Member

    On uploading pictures, the app still crashed. I select 6 pictures to upload. When I selected “Open” the app crashed.

    #2515713

    jalexartis
    Member

    The app is crashing so much that if I did not have the browser, I could not publish. Simply stated, the crashes are very frustrating. I desperately need a cure…

    Sorry.

    Jim Artis

    Previewing was impossible on my last article!

    #2515742

    kokkieh
    Staff

    Hi there,

    A new version of the app was released yesterday. Can you please try updating it, and let me know if you still have the crashing problem? If you open the app on your computer it should automatically prompt you to download the update.

    #2515743

    jalexartis
    Member

    Hi,

    I installed the latest version yesterday and still have the black screen crash. I have noted the app is alive. That is, I can select menu items, but the screen is black.

    I am testing the app on a friends Windows 10 Home Premium Notebook. So far no crash, but I have not tested long enough.

    I will let you know how my testing goes.

    Thanks!

    #2515744

    jalexartis
    Member

    I now have installed version 1.2.1 which is later than 1.1.3 that I installed yesterday. I’ll let you know on crashes. Thanks!

    #2515745

    jalexartis
    Member

    I am experiencing consistent black-screen crashes with WordPress.com App, version 1.2.1. The happen when I enter categories & tags, and just after selecting photographs with the explores as the upload is about to/has begun.

    #2515747

    jalexartis
    Member

    …also after select the X to close a preview.

    At this point, I suspect the video driver: Intel(R) HD Graphics 4000
    Looking for updates, a scan of the Internet says I have the most current driver.

    jaa

The topic ‘WordPress.com App for Windows Crashes’ is closed to new replies.