Would like blog to enable japanese kanji/katakana

  • Author
    Posts
  • #1061094

    larsang
    Member

    My blog comes up goofy not displaying the kanji added how do I get the kanji to add into my article ?(ashi 芦ノ湖
    Blog url: http://budowisconsin.wordpress.com/

    The blog I need help with is budowisconsin.wordpress.com.

    #1061181

    timethief
    Member

    We can only set one interface language for our blogs here > Settings > General.

    #1061194

    larsang
    Member

    Really the reason why I chose this blog was because of another blogger and he uses kanji and katakana with english ?
    http://henka.wordpress.com/

    #1061196

    timethief
    Member

    I flagged this thread for Staff assistance. Please be patient while waiting.

    #1061253

    gymkaltu
    Member

    just thought:
    1. different themes uses different fonts, maybe fonts which is used in your theme don’t support all needed letters, if you choose theme “chateau” problem remains?
    2. maybe you use wrong encoding?(in browser/keyboard settings, copy text from that blog in which text is shown and paste to your blog)

    #1061254

    gymkaltu
    Member

    tested, copied text from http://en.wikipedia.org/wiki/Kanji and created post with that text and everything looks same like in wikipedia, all symbols are shown…(of course maybe it’s wrong kanji, who knows i don’t speak japan)

    #1061255

    1tess
    Moderator Emeritus

    The method of copying kanji and katakana works. I also neither write nor speak Japanese, but writing about Japanese food sometimes requires a word or two to help folks identify an ingredient.

    #1061256

    1tess
    Moderator Emeritus

    The translations forum is intended for those people who work on translating themes to languages other than English. For example: menu titles, widget titles, other text associated with a theme.

    So I’ll move this topic to the Support forum.

    #1061292

    larsang
    Member

    Still waiting on an answer.. I have another article to post but will be very disappointed if I can’t add the kanji which has life to the article .
    Do I just need to cancel leave and find a better blog… again the guy that writes henka as mentioned above uses kanji..

    #1061293

    iruvienne
    Member

    Kanji and kana should be displaying properly on your theme. I’ve also tried copying and pasting some text and it works.
    I can see on your blog you’ve put ・o・・・・・X ・|・C・・・g under a style tag as span style="font-family:MS Mincho;" lang="JA"
    How exactly are you inserting the japanese on your post?
    Try this: simply copy this -> 侍の魂, Add a New Post, paste what you just copied, Save Draft and click Preview. Is it displaying properly now?

    #1061294

    larsang
    Member

    I am writing the article in wordpad then copy paste here.. It transfers to my facebook great but it comes up here as you see.

    ・o・・・・・X ・|・C・・・g

    What do you mean by the lower statement?
    under a style tag as
    span style=”font-family:MS Mincho;” lang=”JA”

    I copied and pasted what you had and it came up fine

    #1061295

    larsang
    Member

    I am using an online tranlating program and when the article is done and kanji or katakana is in my wordpad I copy paste and it comes up with … ??? and junk.

    #1061296

    iruvienne
    Member

    What do you mean by the lower statement?

    I was wondering how that style tag appeared: you don’t need it for japanese being displayed. Seems it came from Wordpad.
    If it’s just when you paste it here that things get unformatted, try pasting it as plain text and see if the problem persists: Edit Post -> click on the “Paste Plain text” button on the Visual Editor- > CTRL+V and “Insert”.

    P.S: I gave Wordpad a try: copy and paste on post works fine for me (it seems to be pasting as plain text too).

The topic ‘Would like blog to enable japanese kanji/katakana’ is closed to new replies.