Write Post and HTML not working

  • Author
  • #12847

    When I try to write a post WP won’t save it. When I click on “SAVE” a warning box pops up asking if I want to navigate away from the page because all changes will be lost. Also, when I try to edit the HTML nothing appears in the pop-up HTML box. It’s completely empty.

    I am unable to post anything. I’ve closed WP and my browser and restarted but the problem continues. Any suggestions?



    if it persists, maybe you should try sending a feedback. they respond quite swiftly



    This worked for me. Turn off the text rich editor and see if you can post then.



    What are you clikcing on when the warning box comes up? You should be clikcing on ‘yes’ as you are coming from the secure side back to your blog which is not https.


    Drmike: I’ve never had this box pop up on WordPress before. Here’s what happens – I’m writing a post and want to publish but when this box comes up it only gives me two choices, “cancel” or “yes to continue”, and if I click yes it sends me to my “manage post” page but the post itself is completely lost. If I click cancel then the box disappears and I’m still looking at my unsaved, unpublished post. There’s no way to win.

    It’s not warning about switching between secure and unsecure sites, it’s warning about loss of information if I navigate away from the page (which makes no sense since I’m clicking “save” or “publish” when this happens).

    I can manage to post after several tries – it’ll finally save or publish my post like it’s suppose to, but this is extremely frustrating and time consuming.



    View, send in a feedback from your Dashboard as it sounds like a backend problem.

    It’s asking you if you want to navigate away from the page because you are going from a secure page to one that’s not secure. That’s how IE handles that in this case.
    (Blame Microsoft for that one)


    Drmike: I sent a feedback, thanks. BTW, I use Firefox so I’m not sure why I get the popup box.



    I know the latest version of Firefox has generated some issues with WordPress and with other software projects. This may be what you are hitting.

    At least Firefox normally fixes it’s issues unlike Microsoft. :)



    I am having the same typ of problem posting. I just upgraded to IE 7 beta 3 though. I do not know if that is the cause of the problem. But I cannot post at this time.



    And it’s giving you some sort of error or what?



    Hello Dr. Mike! I had the same probblem that viewfromea had when publishing the post, a warning box would come up. It warns about the loss of information if I were to navigate away from the page. The choices are to click “Ok” and navigate away and lose information or click “Cancel” in which case you still have your post but of course it is not published. Now I have been using Netscape 8.1 instead of IE 7 beta 3 and so far I have not had problems posting with the Netscape browser. Once in a while I would get a time out, but that is it. I hope that I have clarified the matter for you Dr. Mike. I know that you work hard here and that work is appreciated.



    I have just found this thread – I have been in correspondenec with my hoster http://www.siteground.com thinking it was them – now I see that it is some wordpress / browser issue.

    I get this same error using IE 7 and also Firefox 1.5.07.

    The only difference is the title of the popup box – the options are the same as decribed above.

    I am tearing my hair out on this and unable to post at all to my own blog !!



    I have more information on this error.

    1. I have a blog hosted at http://www.siteground.com – I get the publish error every single time I try to post whther I use IE or Firefox (and all the other tricks like CTRLA/C etc dont work.)

    2. I have a stub of a blog at wordpress http://russab2001.wordpress.com/
    I can publish posts to this with no errors at all. Using IE or Firefox.

    I conclude that it is therefore likely to be a scripting error with the wordpress install at siteground.

    BUT – that was working – it just stopped working a week ago.

    Siteground has reinstalled the default install of wordpress scripts etc.. – the error persists.

    Help !



    I have made a list of ll the scripts running at the moment I hit the “publish” button they are:


    I hope this helps ….



    Ok all pain has gone away.

    I have installed the free BLOGDESK

    and now edit offline with fantastic rich / HTML editing facilities, photo manipulation, and of course a complete back up offline (I dont totally trust the hostign company!)

    What a relief – moral – dont use the WP built in editor.

    au revoir…



    Also to be fair a lot of work has recently been done on tiny MCE and over time I’m sure the glitches will be eliminated. But you are not alone http://wordpress.com/forums/search.php?q=which+editor+do+you+use
    I too turned away from the dark side and downloaded a free copy of BlogDesk months ago. And I’ve shared my positive experience so many times on the forum that I’m sure folks think I own shares in the product. It’s open source and I highly recommend it too.
    The one problem you may experience is that about an hour after uploading via BlogDesk your images may disappear. The way I get around this is to upload them via BlogDesk and then edit the post and upload them into the wordpress editor without pressing “send to editor”. It seems as long as they are in the editor they don’t evaporate. It’s going to be hard to ever get me to give up BlogDesk. And yes! I did try windows live writer and then I went back to BlogDesk. :)



    @ tt When you publish through blogdesk, does it publish as a post or a draft?



    If I choose to postdate then the post is visible in the manage posts section immediately as a draft and at the time I’ve selected it publishes. If I do not choose to posdate then it’s published immediately.



    I am still having no luck with editing the HTML when working on a post. I click the Feedback to point this out, but I’ve gotten no response or help. Seems no matter how I try this, the HTML won’t work.



    thetempest – it is most likely a browser issue. The recent changes to the editor have wreaked havoc on my writing, one of the many items I mentioned this post.

The topic ‘Write Post and HTML not working’ is closed to new replies.