Need help? Check out our Support site, then


Wrong URLs in Recent Posts widget

  1. Hi -- perhaps someone can help me with this. It looks like it's a bug in WordPress.com.

    In the sidebar of my http://historyofmentalhealth.com blog I have the well-known Recent Posts widget showing my last ten posts.

    Unfortunately all these links are the wrong URLs, addresses that seem to be derived from the https URL of my dashboard page.

    Here is an example. Where the link to a post ought to point to
    http://historyofmentalhealth.com/2014/07/28/eduard-einstein/
    instead the link address is
    https://historyofmentalhealth.wordpress.com/2014/07/28/eduard-einstein/

    Yes, people who click on the link get automatically redirected to the correct domain URL. But still, this wrong URL leads to complications. To name just one, in my site stats, clicks on these Recent Posts links are now being registered as clicks on links to external sites (because the https address is to a different domain, the WordPress domain instead of my site's own domain).

    I want to get the correct URLs in my Recent Posts widget, but so far did not find a way to achieve that.

    Could this be solved in some way? Thanks for your help or ideas.

    The blog I need help with is historyofmentalhealth.com.

  2. That seems to be a bug, so I have flagged this for staff.

  3. @raincoaster: Thank you!

  4. Hello there! I've looked at your posts in the Recent Posts column. I am not seeing any with https:// links. Please do the following test for me: right-click on one of the links, and copy the link, paste the link elsewhere and look to see if you're viewing http or https. Let me know.

    Depending on your version, Firefox is automatically set to add https to your address, if you've ever used it to view your site before.

    Here are two links I've found for you, that might assist you in determining if the issue is browser related: https://support.mozilla.org/en-US/questions/933563#answer-356371 https://bugzilla.mozilla.org/show_bug.cgi?id=769994

    You can also check out your site in another browser (preferable Google Chrome), to test whether or not you're being sent to https or not.

    Looking forward to hearing from you! Thanks much.

  5. The relevant problem here is not where the user is being sent, but where she is perceived to have clicked on (an external link, where it should be an internal link).

    Just now, I have a new post that appears in my Recent Posts list as
    https://historyofmentalhealth.wordpress.com/2014/07/31/drug-to-stop-smoking/
    while it ought to be
    http://historyofmentalhealth.com/2014/07/31/drug-to-stop-smoking/

    The user opening the first (wrong domain) URL will be automatically redirected to the second (correct domain) URL, so that's not the problem. The problem is that in stats, she will be wrongly registered as having clicked on an external link. Likewise (for example) Google bots will see these links as external instead of internal.

    This problem is NOT browser related. I see these wrong URLs in Chrome, Firefox, and IE11. I also see them both when I'm logged in as a WP customer, and when logged out.

    Interestingly, this morning for a while I saw correct URLs (http, and the right domain) in the Recent Posts widget. Then, after having added a new post tonight (which will refresh the widget) now I'm seeing the wrong URLs (https, and the wrong domain) again.

    Would it be possible that the Recent Posts is showing these wrong URLs for just some hours each time after having been refreshed, before reverting to the correct URLs?

  6. Hello again, Thank you very much for the detailed description. I was able to recreate the issue you're experiencing on a test site. I've informed our developers about the issue and it is now in their queue. We will be in touch as soon as we have a solution for you.

    In the meantime, thank you for your patience.

Topic Closed

This topic has been closed to new replies.

About this Topic