• Author
  • #1008218


    I spend all this time entering in pictures and typing text for my blog posts, then when I try to post it, it ALWAYS says “Invalid request”. Posting and moving photos around within a blog post is NOT user friendly. It REALLY pisses me off that I spend so much time doing this and then the damn thing won’t even post. I copied it into a word doc before trying to refresh my browswer, which deleted everything of course and when I tried repasting it into a new post, it wouldn’t paste my pictures after I spent all that damn time entering them, resizing them, and rearranging them. You have some major bugs that you need to fix!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! What’s the point of having this site if it’s going to be so crappy and never work?!?!?! Seriously pissed I just wasted all my time for nothing. I will be finding another site to blog on.
    Blog url:

    The blog I need help with is



    (1) How are are connecting to the internet and to

    I’m asking because the way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. Also note that the main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    (2) Exactly which browser and version of it are you using. If you don’t know click here to find out >
    Note: If you are running IE9 in compatibility mode then be aware that it renders as IE7 and IE7 is not supported.

    (3) Have you tried?
    clearing your browser cache and cookies >

    using the browser with all extensions or add-ons disabled

    updating the browser to the latest stable version (not a buggy BETA browser version)

    confirming third party cookies is enabled

    confirming JavaScript is enabled

    confirming Flash is updated and if required installing the latest version of Flash

    (4) Are you logging in using the secure https:// log-in? see

The topic ‘WTF?!’ is closed to new replies.