XML-RPC Not Working

  • Author
  • #1342324

    Wondering if xml-rpc is disabled or the ip address we use to publish is blocked. Any time we go to publish using an offline editor or script from our parent site, we receive transport error – HTTP status code was not 200. This happened on June 10th and since then, nothing will publish via xml-rpc.

    The blog I need help with is leviathynblog.wordpress.com.



    XML-RPC is already enabled by default here at WordPress.com.
    Make sure that you have the correct XML-RPC URL:
    See here http://en.support.wordpress.com/xml-rpc/


    Already knew that and already have the url correct, thanks for the advice though. I have tried everything, we run dedicated servers here with WP.org and I’ve looked into php.ini, see if APC or Varnish was an issue. Literally pulling hair out because I have spent about 10 hours trying to figure it out, nothing.

    I believe our IP address has bee blocked, trying to visit the wordpress.com (or our blog) domain doesn’t load, but wordpress.org does.



    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.



    we run dedicated servers here with WP.org

    Hold it! We do not provide support for WordPress.org installs here at WordPress.COM. WordPress.com and WordPress.org are completely separate and have separate logins. If you don’t have a username account at WordPress.ORG click http://wordpress.org/support/ and register one on the top right hand corner of the page that opens, so you can post to the support forums there and receive advice from WordPress.ORG bloggers.


    Thanks so much. I can understand the address being blocked, it would probably look like spam, but we are using the WP blog like tumblr. Our site leviathynblog.wordpress.com has excerpts on it for leviathyn.com


    Yeah, I understand that. This is for WP.com blog, we host our official blog on WP.org code. Our site is publishing to the WP.com one. But even using an offline editor like Word 2007, we can not reach the wordpress.com domain from the office IP (which is the same IP the servers use).


    And what I meant by the

    we run dedicated servers here with WP.org

    was that I thought perhaps it was something on our end that resulted in not being able to publish, but I can see now that it appears that the ip address is blocked.

    I’m sure they have a filter that looks for automated posts from some PHP header and after so many times, blocks the address (keep down on the spam).

    Thanks again!



    Hi there @leviathynblog,

    Is this still an issue? I took a look at your site and I can about 25 posts all having been made within the last few hours. Is everything working OK now?


    @amightywp Still an issue, our blog on WP http://leviathynblog.wordpress.com/ is still not posting what we have on http://leviathyn.com


    Since we have an exchange server on the same network, I can login, open Chrome, and try to visit wordpress.com and nothing will come up. If I visit any other site, it loads.

    Now if we move off the ip address from the rack and use another, the website loads. If I post using Word 07 from another ip, it works. I think our ip address is being blocked at WP. Since we own all switches and routers including the servers/rack, nothing on our end is blocking the lookup.



    Hey there,

    I am sending an email directly to your address on file to get some additional information from you. If you could please check that address and respond, I would appreciate it!



    I’m getting the same error as the OP.
    Is this caused by IP/Domain restrictions on who can remote post to my WP.com site?


    So after a long email conversation back and forth it seems for us the issue is network related. Some where down the line before you get to WP’s servers provided by provider Peer 1 the connection gets refused.

    If you do a tracert from the server in question or from the client (depending on who can’t reach WP), you’ll notice that the ip address changes about 3 times (do the tracert more than once), this is what I believe is WP’s load balancing cluster (nginx).

    I found two of the three IP addresses reject my incoming request, but the third will let me in and post via xmlrpc, making it like Russian roulette. And of course if you get the two addresses that reject, you have to wait until the DNS lookup expires to try again (from your browser).

    What I did to patch it so to speak was use our host lookup file in Ubuntu (server edition) and route our blog to the one address that works. Although this kinda duct tapes the service together, it will work.

    Unfortunately for a lot of bloggers, you may be using a shared hosting plan, which will not give you access via SSH to change the hosts file. You might have to contact your help desk to see if they can fix the issue for you.

The topic ‘XML-RPC Not Working’ is closed to new replies.