XML tag stripped out of [sourcecode language="xml"]

  • Author
    Posts
  • #1028704

    dougeboy
    Member

    I am trying to post sample XML configuration files on my blog. Here’s an example chunk of XML used to configure a framework called Reactor:

    <object name="User">
        <hasMany name="Address">
            <link name="UserAddress"/>
        </hasMany>
        <hasMany name="State">
            <link name="UserAddress"/>
            <link name="Address"/>
        </hasMany>
    </object>

    I’m placing this in a sourcecode tag like so:

    [sourcecode language="xml"]
    <object name="User">
        <hasMany name="Address">
            <link name="UserAddress"/>
        </hasMany>
        <hasMany name="State">
            <link name="UserAddress"/>
            <link name="Address"/>
        </hasMany>
    </object>
    [/sourcecode]

    When I switch between the visual/textual tab in the post editor these object tags are stripped out. This also happens if I just save the post with the text tab open.

    However, if if I change <object to < object (with a space after the angle bracket) it will not be removed.

    Since I’m trying to display source code and not trying to embed an object using the HTML object tag, this seems a bit confusing.

    Is there a resolution to this problem?

    Thanks,

    Doug

    The blog I need help with is alagad.com.

    #1028939

    cvanhasselt
    Member

    I’m having the same issue, working on a somewhat lengthy explication of regular expressions. There is something amok with the sourcecode shortcode. (say that three times fast!)

The topic ‘XML tag stripped out of [sourcecode language="xml"]’ is closed to new replies.