Need help? Check out our Support site, then

You do not have permission to preview drafts.

  1. I get the following message if I want to open my blog:

    "You do not have permission to preview drafts."

    The URL is
    Can anyone help me, what could be the matter?

    The blog I need help with is

  2. Can you please try clearing out your cache?

  3. I guess that would even delete my saved passwords...
    Could I just try to delete the wordpress-cookies?

  4. So I cleared out cache, but the problem still exists.
    I did last report a comment on my blog, the user had used my name, I don't how that could happen? Maybe this could be the matter?

  5. Here the Noscript-message I got when I klicked on that like-mark (not comment) with my username

  6. I get this same message as well. It just started this morning. Clearing cache and cookies doesn't solve the problem. My blog is

    Jim Amos, MD
    The Practical Psychosomaticist

  7. The Like button uses Javascript, which is one of the things Noscript blocks/alerts. You can simply flag it as 'trusted' or 'allow' in Noscript.

    For support on Noscript please go to or

  8. Noscript does't sound familiar and I don't know if it applies to me. Is it a part of WordPress? If it's a software that you buy or download, I don't have it. Could there be another explanation? Thanks.

    Jim Amos, MD
    The Practical Psychosomaticist

  9. I was referring to 'Noscript Clearclick', this is a add-on/extension for the Firefox browser. It's possible that it's pre-installed if you're working from a corporate network. In that case please contact your local network/system administrator to help you further.

  10. Well I installed the Noscript-application long time before.
    Never got stressed with it until now. The blog-mainpage appeared for a year but now it always shows me "You do not have permission to preview drafts."
    But the message just appears when I klick on that like-mark.

  11. ^ the 'Noscript Clearclick'-message

  12. It appears that we had a temporary issue relating to previewing draft posts which has now been resolved.

    Let me know if you have any further questions as I'm here to help. :)

    Have a great day!

  13. Thanks so much!

    Jim Amos, MD
    The Practical Psychosomaticist

  14. Still have the same problem.

  15. Since the issue has been recently resolved, can you please try clearing out your browser cache again?

  16. No, it didn't succeed...sorry, still the same as before.

  17. In that case it might be a noscript issue, please read my previous reply at

  18. I am having the same problem.

  19. @amypcase Do you get the exact same error message? Could you send us a screenshot of the page where you're seeing this? You can upload the screenshot to your blog's media library.


  20. Problem seems to be solved by itself. Without changing anything I can call up the mainpage of my blog.

  21. Our developers have just fixed the issue. Feel free to contact us if you have any other questions.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.