You don’t have permission to do that

  • Author
    Posts
  • #6290

    Hi everyone (and particularly anyone who might be able to help me)

    I’ve created a blog, with sample categories and posts. Now, when I go to dashboard> manage> posts, categories and pages, and try to delete so that I can post the real thing, I am told that I don’t have permission to do that. I am the only user on my blog. I have another samples set up, with different email addresses, and am getting the same message on this one too.

    I’d be very grateful if someone could help this rather basically educated blog user!

    #6433

    taraden
    Member

    I am also having troubles deleting posts and links as well through my dashboard. I have no idea why this is happening, as I have deleted things through that method before. If anyone could help that would be great!

    #6457

    dwproctor
    Member

    I have also experienced this issue. I have only just joined WordPress but I found if you edit the post and delete from in the post it should delete it!!!

    #6466

    deaconsteve
    Member

    I’m also relatively new but try going to:
    My Dashboard – Users – Authors and Users;
    Set the role of _ checked user to “Administrator”
    then hit “Update”
    Ciao,

    #6505

    Hi deaconsteve, dw and taraden

    Steve, thanks for your suggestion but … I’m the only person on my site, and only I appear in the Authors/users section as the adminstrator. The box next to my name is greyed out and unclickable, but I am set as the adminstrator – I’ve set up three sample blogs, mairetries, mairretriesagain and monthliesblog, and I’m experiencing the same difficulty on all of them. So, I must have done something wrong somewhere, but I don’t know how or where! I’m going to be using one of them properly soon, and really want to be able to clear all the old posts etc, which are all samples. I know I’ll also need to change categories and or/delete them, but don’t stand much of a chance at this rate. It seems others are having the same problem? I know I can delete posts from within the post itself, but don’t know if the same hold true for seleting categories? I’m tempted to delete all three, and sign up for a new email address at somewhere like hotmail, and start a whole new blog, but who’s to say the same thing won’t happen again? I wanted to use the sample blogs as places to practise my very basic blogging skills! So if anyone out there has any ideas as to how to get around this problem, please let me know. Maybe deleting and restarting is the only way to go? (sigh)

    #6527

    suzsays
    Member

    You’re not the only one. There must be a WordPress issue b/c I’m experiencing the same issue and have the exact same situation. Maybe it will be self-correcting soon… :(

    #6551

    silentblast
    Member

    I too am having the same problem. I can not delete stuff. I was messing around to get used to the concept and now find myself not being able to delete. It’s stupid if you ask me. C’mon WordPress. get ON THIS!

    #6553

    I love the way the wordpress blogs work. I tried a blogspot blog to start off with, and then discovered all the functions of wordpress via Miss Snark. I’ve read many of the posts here which detail how hard the wordpress team works to make their blogs so user friendly (and beleive me, they are – I set up my blog very easily!), so I’m sure this too will be sorted out in time. I’m just relieved that I’m not the only one experiencing this problem, as it means that I haven’t done anything wrong and it’s just a bug that needs to be fixed. So I’m going to do as others have been told to do at times, choill drink a cup of coffee or two, and check back regularly to see if a fix is recommended or has been made!

    #6569

    If you are having problems like this, you should report it as a bug through the feedback link in your dashboard. It would get the developers’ attention right away.

    #6573

    Hi talkingbase

    I’ve reported directly through the feedback link twice now. Don’t know how many times constitutes being a pain in the rear end! I don’t have to have the blog proper up and running until the last week of March, so hopefully things will be sorted by then.

    #6732

    slowpoison
    Member

    Good news! I just joined wordpress… yeah that’s the good news… but wait.. there’s more. I found a way to delete posts. You go and edit a post… on the same page there’s a delete button and that seems to work. Whereas, if you directly try to delete the post from Manage Posts, it gives you “You don’t have permissions to do that”.

    HTH
    -slowpoison

    #6733

    tinyasian
    Member

    I’m also having the same issue. I am the creator of the blog, under users and authors the login name I’m using is classified as administrator, yet I can’t create categories nor delete or move any posts etc.

    #6735

    Hi! I’m experiencing the same problems… You can see the error on http://student.dei.uc.pt/~pgms/pub/error.gif.

    Damn the site is very important to me, and I’ve got it somewhat stalled because this.

    Still not works deleting and creating categories.

    Grrr…

    Greetz to all.

    #6774

    starboard
    Member

    Well, the problem must not be fixed yet because it is May and I’m getting the message as well.
    Even if there is a way around it, one should be able to manage their own posts!

    #6775

    podz
    Member

    Please send feedbacks in for this issue.

    #6827

    gcmouli
    Member

    starboard:

    It is August and it still happens off and on. I was able to do it
    yesterday but cant do it today.

    Workaround: click edit to edit the post. Go in and scroll down and
    click the ‘delete this post’ button. This works.

    #6828

    timethief
    Member

    Podz is on vacation so please don’t forget to send in a feedback with the link to this thread in it, ok?

    #6829

    drmike
    Member

    Andrew and Barry are covering. We’ve been trading emails on the future posts issue.

    #6834

    lloydbudd
    Member

    Are people still seeing this issue?

    #6835

    Thanks for asking. I have just started searching for a solution, but I am experiencing the “You don’t have permission…” problem when trying to delete a link category.

    I recently upgraded from 2.0.1 (I think) to 2.0.4; I don’t recall having the problem prior to the upgrade. I own or manage a significant number of WordPress blogs; this is the first on which I have encountered this problem.

The topic ‘You don’t have permission to do that’ is closed to new replies.