"You have failed to authenticate with the WordPress.com API"

  • Author
    Posts
  • #1046810

    unit076
    Member

    Simply put, I am unable to use WordPress.com stats. That line shows up when I open the Stats page in dashboard. I’m having a new site for my blog, located here: stoplayingame.com.

    Other part of Jetpacks like comments, subscription, contact forms, etc, works though. Only the Stats which is having problems. I have tried deactivated the whole Jetpack plugin, then activated and reconnected again, but the problem remains.

    I’ve been trying to Google for solutions, and have found some topics on WordPress support forums. But it seems nobody have the solution for this problem (except by deactivating)
    Blog url: http://stoplayingame.com/

    The blog I need help with is stoplayingame.com.

    #1047014

    I’m sorry for the inconvenience, and I’ll be happy to take a closer look.

    Can you take an uncropped screenshot of your Jetpack screen, then upload the image to your Media Library and paste the direct file URLs in your reply to this forum thread? Thanks.

    #1047059

    unit076
    Member

    Sure. Here are two screenshots, one from the Jetpack screen, and another is from the Jetpack Site Stats screen:

    http://stoplayingame.com/wp-content/uploads/2012/10/jetpack.png

    http://stoplayingame.com/wp-content/uploads/2012/10/jetpack2.png

    #1047065

    Thanks! Can you try deactivating Jetpack, download a fresh ZIP file of Jetpack, then upload the Jetpack plugin folder manually via (S)FTP?

    http://codex.wordpress.org/Managing_Plugins#Manual_Plugin_Installation

    #1047066

    unit076
    Member

    Do you mean by that is to replace the old Jetpack files? If yes, okay… I have tried deactivating Jetpack, downloaded the fresh new file, uploaded the plugin via FTP and replaced the old one, but still… it doesn’t work. :/ It still says the same error: “You have failed to authenticate with the WordPress.com API”.

    #1047080

    Do you mean by that is to replace the old Jetpack files?

    Yes, thanks for giving that a try. :-)

    Can you try clearing your browser cache, then sign out and back into your WordPress.com account?

    If that doesn’t change things, can you then try an alternate browser to see if you get the same result? You can download the latest browser versions here:

    http://browsehappy.com/

    If you get the same result as before, can you try deactivating all other plugins, and temporarily switch to a default theme (like Twenty Eleven or Twenty Twelve) in case it’s a plugin/theme incompatibility?

    #1047083

    unit076
    Member

    Okay… have tried cleared the browser cache, tried with different browsers, tried with different computers, all with the latest browsers… also tried deactivating all plugins (except Jetpack) and reverted to default theme.

    Still not working. :(

    I tried visiting the Stats page on WordPress.com here: http://wordpress.com/#!/my-stats/?unit=1&blog=41715684

    Surprisingly, some of the data seems to be recorded. Here’s a screenshot: http://i.imgur.com/eS6zx.png

    #1047084

    unit076
    Member

    Oh, and there’s another thing… (sorry, wanted to edit the post but it seems I cannot)

    The stats icon on wp-admin global panel (not sure what is its name) seems to be always broken. Here’s a screenshot: http://i.imgur.com/leQUg.png and here’s the image url: http://stoplayingame.com/wp-admin/admin.php?page=stats&noheader&proxy&chart=admin-bar-hours-scale

    When I open the image URL, it says the same error: You have failed to authenticate with the WordPress.com API. Also, the stats smiley also does not seem to appear even when it is not hidden.

    This happens on default Twenty Eleven, Twenty Ten, and my custom theme. : /

    #1047085

    macmanx
    Staff

    Are you running the WordPress.com Stats plugin along with Jetpack?

    #1047086

    unit076
    Member

    Nope, only the Jetpack…

    #1047087

    Okay, thanks for the additional information. I’ll see if our Jetpack developers have any other suggestions, and I’ll be sure to reply back to this forum thread when I hear from them.

    Thanks for your patience!

    #1047089

    unit076
    Member

    Okay, thank you for your support, I’ll be waiting for it. :)

    #1047090

    We’d like to debug something from our end which requires you to try viewing your stats right now to trigger it.

    Can you try viewing your stats again?

    #1047105

    unit076
    Member

    I’m sorry, I just have got the chance to online…

    I tried view my stats, but the same error remains… am I late?

    #1047110

    Not at all, we needed you to view your stats so we could trigger something on our end to view the errors. I’ll reply back when I have another update.

    Thanks for your patience. I appreciate it.

    #1047111

    Can you ask your host if they are blocking Authorization headers on outgoing HTTP/HTTPS requests?

    One of our developers wrote a simple test script that uses cURL. If your host supports cURL (it probably does), they can use it to test if Authorization headers are being sent correctly, though I imagine they are fully capable of coming up with their own test.

    I’ve just sent the script to the email address linked to your WordPress.com account.

    If you are able to upload files to your host (you may or may not be able to), you can run the test yourself by uploading the attached PHP file to some web-accessible directory on your host, then loading the corresponding URL in your web browser. For example, that URL might look something like:

    http://stoplayingame.com/test-outbound-authorization-headers.php

    #1047116

    unit076
    Member

    Bryan, I’m sorry for the late reply.

    Have just cheked it and I got this:
    Warning: curl_exec() has been disabled for security reasons in /home/stopecom/public_html/test-outbound-authorization-headers.php on line 16

    I asked the host if it’s possible to enable it, but they said it’s impossible to do that since I’m in a shared hosting… feels like a really dead-end for me.

    Could I ask for alternative solutions? :/

    #1047117

    kathrynwp
    Staff

    Hi there, thanks for letting us know you weren’t able to run the debugging script. I will get back to you with next steps.

    #1047118

    mdawaffe
    Staff

    Hi,

    Not being able to run the test script isn’t a deal breaker, it just means you’ll need to ask your host for help. Here’s a suggestion on what to ask them:

    —-

    Hi [My faithful Host],

    I’m having trouble with the Jetpack WordPress Plugin created by WordPress.com: http://jetpack.me/

    I’ve spoken with their developers, and, so far, their best guess is that the problem because Authorization headers on outbound HTTP/HTTPS requests are being blocked. They’re not sure, though, because I was unable to run a test script they sent me; the test uses curl_exec(), which is disabled on my site.

    Are Authorization headers blocked on outgoing HTTP/HTTPS requests? Is there a way for me to test that myself?

    Thanks for your help,
    Unit

    —-

    If your host is blocking Authorization headers, and they are unwilling to unblock them, Jetpack will unfortunately not work on your host.

    If they are not blocking Authorization headers, and the problem is something different, we’ll keep working on a solution.

    Sorry for all the hassle,
    Mike

The topic ‘"You have failed to authenticate with the WordPress.com API"’ is closed to new replies.