Your site has no hreflang tags.

  • Author
    Posts
  • #3227211

    My site does not appear in Google search results in Japan. The website is in Japanese am an English speaker living here in Tokyo.The website has been published for about a month. I changed the International Targeting on Google Search Console today but under languages I receive the following message: ‘Your site has no hreflang tags’. Im a complete beginner and found some info on adding <link rel=”alternate” hreflang=”jp” tags but have no idea if this will help or how to do this. Any help would be much appreciated. Thanks

    The blog I need help with is cambridgeeikaiwa.com.

    #3228715

    damiannep
    Staff

    Hi there,

    We add an html tag to your site for the language settings. It is set as Japanese for your site due to the language chosen here:

    https://wordpress.com/settings/general/cambridgeeikaiwa.com

    If I search for your site in Google with Japanese language settings, I do see your site show up as demonstrated in this screenshot:

    I hope this helps.

    #3228719

    damiannep
    Staff

    My apologies. Here is the link for the image: https://cld.wthms.co/MFrxjM

You must be logged in to reply to this topic.