Youtube Embed not working

  • Author
    Posts
  • #509464

    magpie9901
    Member

    Hi

    Im having trouble embedding video from youtube, i regularly do this on my blog and all of a sudden the videos arent showing up in the posts theres a space where the video should be but nothing loads. I have checked the embed code of a previous video from a few days ago and compared that to the embed code of the same video today and there is alot more code than the other day, im not sure if this extra code is whats causing the problem. Im currently using Windows Live Writer Beta.

    Below is the code for the embed of the same video taken a few days apart and you can clearly see the size difference.

    [CODE AS OF THE 9TH OF AUGUST]
    <div style=”width:640px;display:block;float:none;margin:0 auto;padding:0;” id=”scid:5737277B-5D6D-4f48-ABFC-DD9C333F4C5D:8bfd53eb-1a58-47c1-9ceb-f72aaf2414ce” class=”wlWriterEditableSmartContent”><div>[youtube=http://www.youtube.com/watch?v=h_fsM6LBi54&hl=en_GB&fs=1]</div></div>

    [CODE AS OF TODAY 14TH OF AUGUST]
    <object width=”640″ height=”385″><param name=”movie” value=”http://www.youtube.com/v/h_fsM6LBi54?fs=1&hl=en_GB&hd=1″></param><param name=”allowFullScreen” value=”true”></param><param name=”allowscriptaccess” value=”always”></param><embed src=”http://www.youtube.com/v/h_fsM6LBi54?fs=1&hl=en_GB&hd=1″ type=”application/x-shockwave-flash” allowscriptaccess=”always” allowfullscreen=”true” width=”640″ height=”385″></embed></object>

    Any help on this subject would be greatly received as i rely alot on the embedding of youtube videos on my blog.

    Kind Regards
    Danny

    The blog I need help with is magpie-gaming.com.

    #509573

    raincoaster
    Member

    We can’t give technical advice without the URL of the blog in question, starting with http.

    #509574

    magpie9901
    Member
    #509575

    raincoaster
    Member

    Thank you. If you go to youtube.com you’ll see that they’ve put in some changes for their video, and as you can see from the forum, WP.com has been doing some changes of its own. The result is that something has been mistranslated between YouTube and WordPress.com.

    The solution until staff fixes it is to use the SHORTCODE method of putting in YouTube videos. That is the only method that always works, no matter what.

    Shortcode:

    [youtube=URL]

    in the example above it would be

    [youtube=http://www.youtube.com/v/h_fsM6LBi54]

    #509603

    magpie9901
    Member

    ahh okay cool, phew! thank you very much for your help, hope they resolve this fully soon.

    Kinds Regards
    Danny

    #509606

    matt
    Staff

    Also, if you just put the Youtube URL on its own line, it’ll turn that into an embed too.

The topic ‘Youtube Embed not working’ is closed to new replies.